2 image maps on a single web page - some areas don't work

RESOLVED INVALID

Status

SeaMonkey
General
--
major
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: John Brown, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

If 2 or more image maps are on the same web page, some areas don't appear until
you "tab" your way through the links.  You still can't click on these areas but
you can follow them if you hit the enter key....

Reproducible: Always

Steps to Reproduce:
1. goto http://www.uscg.mil/legal/index.htm
2. along the left side are several image map areas that don't work
- however if you "tab" your way through the links - you will see that they are
there; you just can't click on them (you have to hit the enter key to follow them)

Actual Results:  
Some image map areas work - and some don't

Expected Results:  
Mouse should indicate linked image map areas when more than 1 map is on a web page

I have some DIVs/layers on the page but the HTML for the image maps is pretty
darn clean, I think.  All rectangles with first point in upper left, second
point in lower right...right?

Comment 1

16 years ago
Works for me 2002-11-30

Can you reproduce this problem on a new build?
(Reporter)

Comment 2

16 years ago
Really sorry, here. Turns out I had over-lapping regions defined in my
"Div" tags (for absolute positioning) and this was effectively
"turning off" the image maps areas where the div regions overlapped.

So - while my bad HTML worked in internet exploder, it probably shouldn't have.

Here's a picture to clarify:


---------------------------------------
- Div region #1 - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - -
X X X X X X X X - - -               - -
Div region 2 X - - -     image     - -
X X X X X X X X - - -    map "B"    - -
X X X X X X X X - - -  inside div   - -
X           X X - - -       #1      - -
X   image   X X - - -               - -
X  map "A"  X X - - - - - - - - - - - -
X inside d2 X X - - - - - - - - - - - -
X           X X - - - - - - - - - - - -
X X X X X X X X - - - - - - - - - - - -


My problem was with image map "A".  Because of overlap in my DIVs, image map A
simply wouldn't work - but image map B - worked fine (no overlap).

To fix my own image map problem I simply redined my DIVs so that they  (divs 1 &
2) didn't overlap.

So you should probably close this bug out.

Sorry for the false alarm.

Keep up the great work! I use mozilla exclusively.

Best Regards,
John Brown

Comment 3

16 years ago
No problem.  Thanks for helping out

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.