Closed Bug 1764322 Opened 3 months ago Closed 3 months ago

Live languages are not synced between profiles

Categories

(Firefox :: Sync, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox99 --- disabled
firefox100 --- affected
firefox101 --- affected

People

(Reporter: ciprian_georgiu, Unassigned)

References

(Blocks 2 open bugs)

Details

Affected versions

  • latest Nightly 101.0a1
  • Beta 100.0b4

Affected platforms

  • Win 10 x64
  • Ubuntu 18.04 x64
  • macOS 11

Steps to reproduce

  1. Launch Firefox on a profile A.
  2. Launch a second instance of Firefox on a profile B.
  3. In one of the browsers, from about:preferences, "Language" section , change the language to a difference one than default (e.g. Italian).
  4. Perform a sync to both instances of Firefox.

Expected result

  • The languages are synced between the Firefox profiles.

Actual result

  • The languages are not synced between the Firefox profiles.

Regression range

  • Not a regression, more like an implementation bug, since it can be reproduced after Live language reloading feature was implemented.
  • The issue cannot be reproduce on Release 99.0.1, where the above feature is not landed yet.

Additional notes

  • This issue can be reproduced with some of the most used languages: en-US, de-DE, fr-FR and zh-CN.
Blocks: syncmore
Priority: -- → P3
Has STR: --- → yes

I'm not sure this is a bug. Asa and Greg, what do we want the sync behavior to be for languages?

Flags: needinfo?(gtatum)
Flags: needinfo?(asa)

I think it's a valid configuration to have different languages in different browsers. For instance your laptop could have English as your working language, and then you could prefer Spanish on another device you use for more personal things. In addition, the browsers could have been built with different languages, and require langpacks to support them. This would mean ensuring that langpacks are supported for the browser, and can be downloaded.

I think my recommendation here would not to support it unless we find new clear evidence that it should be. This is for two reasons:

  • The user could prefer to have multilingual devices.
  • There is complexity and risk in supporting it due to multiple configuration and builds, and the requirement of downloading and installing langpacks.

If we did decide to support this feature, then I think it would need some additional considerations such as adding it to the list of options to sync, since a user might prefer not to actually sync a language. I would consider this a new feature request, and not a bug.

Flags: needinfo?(gtatum)

Thanks for the bug and the comments - given the complexities here and given the initial request was via QA and not via an organic user, I think WONTFIX is the correct outcome here.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
Flags: needinfo?(asa)
You need to log in before you can comment on or make changes to this bug.