Status

()

Core
Networking
VERIFIED DUPLICATE of bug 174941
16 years ago
16 years ago

People

(Reporter: Tobias Meyer, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

Beginning with mozilla 1.2b Mozilla ignores my.pac script which has been working
with the previous versions of Netscape and mozilla.
The script is served by an apache web-server (linux). It is not complicated:
function FindProxyForURL(url, host)
{
        if (host == "majestix.dkgd.de") return "DIRECT";
        if (host == "localhost") return "DIRECT";
        if (url.substring(0, 5) == "http:" || url.substring(0, 4) == "ftp:"||
url.substring(0, 6) == "https:"|| url.substring(0, 7) == "gopher:") return
"PROXY my.proxy.com:3128; DIRECT";
        else return "DIRECT";
}

I tried changing the line ending from unix "\n" to DOS "\r\n" because it was
stated in another bug that this had caused problems before but it did not help.

There are no errors on the javascript console.

Reproducible: Always

Steps to Reproduce:
1. change the automatic proxy configuration url to
http://wherever.the.server.is/proxy.pac
2. with the script as mentioned above


Actual Results:  
only direct connections are made

Expected Results:  
contact the proxy server

I hope I'm not submitting an old bug. There are some bugs describing this
behaviour but they all seem to refer to older mozilla versions.
Please follow the release notes and install in an empty directory.
(or you can now close mozilla and delete the file compreg.dat)

FYI: You can't also download files if you installed over an older build without
deleting old files in that directory.


*** This bug has been marked as a duplicate of 174941 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
QA Contact: benc → junruh

Updated

16 years ago
Summary: Mozilla ignores PAC automatic proxy configuration script → PAC: ignores cript
You need to log in before you can comment on or make changes to this bug.