Closed Bug 1766685 Opened 9 months ago Closed 6 months ago

Consider class A breakpoints when performing named page fragmentation

Categories

(Core :: CSS Parsing and Computation, defect)

defect

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox105 --- fixed

People

(Reporter: alaskanemily, Assigned: alaskanemily)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Our current logic implemented in bug 1740366 does not consider whether a frame satisfies the spec's definition of whether the page property applies to the frame: https://www.w3.org/TR/css-page-3/#using-named-pages

This requires that the frame satisfies the requirements to be able to cause class A breakpoints, as defined in: https://www.w3.org/TR/css-break-3/#btw-blocks

This requires that the frame be block-level for the page property to be read and propagated. We have a few tests implemented in bug 1740366 (page-name-{img,canvas}-00[1-2].html) which should fail when this is correctly implemented. Tests should also be added to check for other elements, like span which generates an anonymous containing frame.

Severity: -- → S3

Instead, do this just before we actually construct frames for items.

This has issues with replaced frames currently, as either the
insert-page-break function isn't happening for these elements or it is being
called and child elements of replaced frames are cleared/ignored. This is the
main TODO remaining.

Blocks: 1723234
Blocks: 1779645
Attachment #9284613 - Attachment description: Bug 1766685 WIP - Do not perform page-breaks in the destructor of the page name tracker RAII struct → Bug 1766685 - Do not perform page-breaks in the destructor of the page name tracker RAII struct
Assignee: nobody → emcdonough
Status: NEW → ASSIGNED
See Also: → 1782324
Pushed by emcdonough@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97613a0619b2
Do not perform page-breaks in the destructor of the page name tracker RAII struct r=dholbert
Blocks: 1782597
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

Gah, sorry, comment 4 was intended for another bug (Bug 1779645). Reposting there.

Attachment #9289753 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.