Closed Bug 1767606 Opened 2 months ago Closed 2 months ago

Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling (e.g., 125%) and locales (e.g., ar)

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
Windows
defect

Tracking

()

VERIFIED FIXED
102 Branch
Iteration:
102.1 - May 2 - May 13
Tracking Status
firefox-esr91 --- unaffected
firefox100 - verified
firefox101 - verified
firefox102 --- verified

People

(Reporter: mcoman, Assigned: Mardak)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

[Notes]:

  • This issue is NOT reproducible on Windows 11 x64, macOS 11.6, and Linux Mint 20.2 x64.

[Affected versions]:

  • Firefox Release 100.0 - Build ID: 20220428192727

[Affected Platforms]:

  • Windows 10 x64
  • Windows 8.1 x64

[Prerequisites]:

  • Have the environment set to "Stage (preview)" using the "Remote Settings Devtools" add-on.
  • Have the user.js file saved to your PC.

[Steps to reproduce]:

  1. Open the browser using the profile from the prerequisites.
  2. Navigate to the profile folder and paste the user.js file from the prerequisites.
  3. Restart the browser.
  4. Observe the spotlight.

[Expected result]:

  • The "TCP" spotlight is successfully displayed and all the elements are visible.

[Actual result]:

  • Scrollbars are wrongly displayed inside the default "TCP" spotlight.

[Notes]:

  • This issue seems similar with bug 1766997. @Ed could you please take a look over this?
  • Attached a screen recording of the issue.
Flags: needinfo?(edilee)

Similar to bug 1766997 (which is also still affected at 125% scaling). I'll try to see if we can adjust to some other size to avoid scrollbars. Underlying problem seems to be that bug 1758187 changed the width to an odd number.

Assignee: nobody → edilee
Iteration: --- → 102.1 - May 2 - May 13
Flags: needinfo?(edilee)
Keywords: regression
Priority: -- → P1
Regressed by: 1758187
See Also: → 1766997
Summary: [Rollout Phase 1] Scrollbars are wrongly displayed inside the "TCP" spotlight → [Rollout Phase 1] Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling including 125% and 225%

Set release status flags based on info from the regressing bug 1758187

Has Regression Range: --- → yes

Modifying the severity of this issue to S3 as it is reproducible only on Windows if the OS scaling level is set to 125% and 225%.

Severity: S2 → S3

Are 101/102 really unaffected?

Flags: needinfo?(mcoman)
See Also: → 1768730

[Tracking Requested - why for this release]: The TCP phase 1 message will target 100.0.1+ beta/release and stopped mid 101 release (for phase 2 that doesn't want the message shown anymore).

Potentially we can fix this up in 100 and/or 101 as the rollout increases to 100% (from maybe 25%) less than a week before 101 release, so some(/many?) users might not see the message until 101 anyway.

I'll try adjusting some Firefox sizing to see if the scrollbars can go away (as remote adjustments have been unsuccessful).

This seems like something we'd be OK uplifting if a low-risk patch is available, but also edge case enough that we don't need to track.

Duplicate of this bug: 1768849
Summary: [Rollout Phase 1] Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling including 125% and 225% → Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling (e.g., 125%) and locales (e.g., ar)
Attachment #9275954 - Attachment description: Bug 1767606 - Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling including 125% and 225% r?mviar → Bug 1767606 - Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling (e.g., 125%) and locales (e.g., ar) r?mviar
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af018933f012
Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling (e.g., 125%) and locales (e.g., ar) r=mviar
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 102 Branch

I‘ve verified this issue using the latest Firefox Nightly 102.0a1 en-US, ar locales (Build ID: 20220511214930) on Windows 10 x64, Windows 8.1 x64, and macOS 12.3.1.

  • Even if the OS scaling level is set to 125, the scrollbars are no longer displayed on the “pref-flip-staged-rollout-total-cookie-protection-by-default”, "better-internet-c-rollout-global" and "peace-of-mind-a-rollout-global" messages.
Status: RESOLVED → VERIFIED

Comment on attachment 9275954 [details]
Bug 1767606 - Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling (e.g., 125%) and locales (e.g., ar) r?mviar

Beta/Release Uplift Approval Request

  • User impact if declined: Scrollbars appear for spotlight messages for some users with certain Windows zoom and locales. TCP spotlight is rolling out to 100.0.1 and there's existing Fx100 "ECO" messages targeting infrequent+casual activity level.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes comment 11
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Minor CSS adjustment to widths to avoid rounding errors
  • String changes made/needed: none
  • Is Android affected?: No
Attachment #9275954 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Attachment #9275954 - Flags: approval-mozilla-release?

Comment on attachment 9275954 [details]
Bug 1767606 - Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling (e.g., 125%) and locales (e.g., ar) r?mviar

Approved for 101.0b6.

Attachment #9275954 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9275954 [details]
Bug 1767606 - Scrollbars are wrongly displayed inside the "TCP" spotlight at various scaling (e.g., 125%) and locales (e.g., ar) r?mviar

Approved for 100.0.1

Attachment #9275954 - Flags: approval-mozilla-release? → approval-mozilla-release+

I‘ve verified this issue using Firefox Beta 101.0b6 en-US, ar locales (Build ID: 20220512193916) and Firefox Release 100.0.1 (Build ID: 20220512201909) downloaded from the Treeherder on Windows 10 x64, Windows 8.1 x64, and macOS 12.3.1.

  • Even if the OS scaling level is set to 125, the scrollbars are no longer displayed on the “tcp-spotlight-opt-in-rollout”, "better-internet-c-rollout-global" and "peace-of-mind-a-rollout-global" messages.
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.