Closed Bug 1767815 Opened 2 months ago Closed 2 months ago

[HiDPI] Graphical artifact on the bottom right corner of tooltips

Categories

(Toolkit :: Themes, defect, P2)

Unspecified
Windows
defect

Tracking

()

VERIFIED FIXED
102 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox100 --- unaffected
firefox101 --- verified
firefox102 --- verified

People

(Reporter: itiel_yn8, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image Screenshot

See screenshot, this is very similar to bug 1704040.
This is visible also on light theme.

No longer blocks: 1765423
Severity: -- → S4
Type: enhancement → defect
Keywords: regression
OS: Unspecified → Windows
Priority: -- → P2
Regressed by: 1765423

Set release status flags based on info from the regressing bug 1765423

:emilio, since you are the author of the regressor, bug 1765423, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)
Attached image Screenshots.png

I can reproduce this issue.

Err, comment 3 looks much worse than it should be (comment 0). What are your DPI settings and OS version? Also do you see the same offset on context menus? Thanks.

Flags: needinfo?(emilio) → needinfo?(nayinain)
Flags: needinfo?(emilio)

(In reply to Emilio Cobos Álvarez (:emilio) from comment #4)

Err, comment 3 looks much worse than it should be (comment 0). What are your DPI settings and OS version? Also do you see the same offset on context menus? Thanks.

DPI: 100%
OS: Windows 10.0.19043
No,Occurs only in the tooltips of the tabs or bookmarks.

Flags: needinfo?(nayinain)
Has Regression Range: --- → yes

(In reply to Emilio Cobos Álvarez (:emilio) from comment #4)

Err, comment 3 looks much worse than it should be (comment 0). What are your DPI settings and OS version? Also do you see the same offset on context menus? Thanks.

I found the cause of the issue. I don't know when I set browser.proton.places-tooltip.enabled to true.

Depends on: 1768004
Depends on: 1768278
Flags: needinfo?(emilio)

Looks fairly ugly in HiDPI, and release doesn't have shadows either, so it's
probably fine.

This allows me to clean-up -moz-window-shadow, as with bug 1768278 this is the
last use in the tree.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Blocks: 1768285

Comment on attachment 9275573 [details]
Bug 1767815 - Remove shadow from windows tooltips. r=dao,Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: Bug 1765423
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Removes one CSS declaration added in bug 1765423 which causes an ugly artifact in HiDPI. We might want to keep it as-is tho, since the artifact is also on context menus.
  • String changes made/needed: none
  • Is Android affected?: No
Attachment #9275573 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca383a27eb51
Remove shadow from windows tooltips. r=dao
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 102 Branch
QA Whiteboard: [qa-triaged]

Comment on attachment 9275573 [details]
Bug 1767815 - Remove shadow from windows tooltips. r=dao,Gijs

Approved for 101.0b5.

Attachment #9275573 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Reproduced this issue on an affected Nightly build (2022-05-04) on Windows 10 x64.
Verified as fixed on Firefox 101.0b5 (20220510144626) and Firefox 102.0a1 (20220510213954) on Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.