Closed Bug 176803 Opened 17 years ago Closed 13 years ago

can't add vcard to addressbook

Categories

(MailNews Core :: Address Book, enhancement)

x86
Linux
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 79709

People

(Reporter: einojacobs, Unassigned)

Details

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

A vcard received as an attachment can't be added with one mouse-click to
the address book.
In netscape 4.X this works well, but in mozilla it doesn't.
This is an important feature for business class email that prevents my
migration from netscape 4.X to mozilla.
Please improve vcard handling with urgency.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Severity: normal → major
Dupe of bug 20304?
QA Contact: trix → yulian
QA Contact: yulian → stephend

*** This bug has been marked as a duplicate of 20304 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Not duplicate. This bug applies to importing vCards. Bug 176803 applies to
exporting them
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
I can confirm this bug. There is still no way to import a vCard attachment.
Tested with Mozilla Thunderbird 1.5 beta1

Ideally, clicking on a vCard attachment would prompt you to import it into your
address book. The next best thing would be an option to import a vCard from a
file in the address book editor. As it stands right now, there is no way to get
the contents of a vcard into your address book, other than opening the vcard in
some other app, and copying-and-pasting each field one-by-one into Thunderbird's
address book editor :(

Fixing component to Address Book, and severity to enhancement.
Assignee: mscott → nobody
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Component: MailNews: Attachments → MailNews: Address Book
Ever confirmed: true
QA Contact: stephend → addressbook
Attached file sample vCard file for testing (obsolete) —
Here is a sample vCard file that can be used for testing.
Here is a sample vCard file that can be used for testing.
(In reply to comment #6)
> I can confirm this bug. There is still no way to import a vCard attachment.
> Tested with Mozilla Thunderbird 1.5 beta1
> 
> Ideally, clicking on a vCard attachment would prompt you to import it into your
> address book. 

Right now, this is exactly what happens for me, at least with vCard 2.1 version
vCards.  It's pretty likely that we fall over on vCard 3.0 items like you've
posted above, as our parser doesn't support those.  Can you try looking at a 2.1
vCard and see if that works for you?
Here is a sample version 2.1 vCard that I found at
http://www.bitfolge.de/?s=phpvcard

It does not work for me either. If I mail it to myself, it just behaves as an
attached text file. I cannot do anything with it other than saving it to disk.
Attachment #197561 - Attachment is obsolete: true
Attachment #197563 - Attachment description: sample vCard file for testing → sample vCard file for testing (version 3.0)
Can you attach the entire mail with vCard attached where you seeing this problem?
Here is an e-mail with a vcard attached. I notice, looking at the raw message,
that it is attached as text/plain.
That content type is the problem; if you tell Thunderbird to attach a vCard to
all your messages, it will do the correct content-typing.  How did you attach
this one -- using the generic attachment feature UI?
Yes. I attached that vCard the same way I would attach any other file.

I see the option in Account Settings to "Attach My vCard to Messages", but I
cannot attach a file there, I have to re-type each field manually. There is no
option anywhere to import a vcf file.
Status: NEW → RESOLVED
Closed: 17 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79709
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.