Closed Bug 1768293 Opened 3 months ago Closed 3 months ago

Intermittent dom/ipc/tests/browser_domainPolicy.js | Test timed out -

Categories

(Core :: DOM: Content Processes, defect, P5)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered])

Filed by: ctuns [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=377198086&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/D33kI7GLQAC47gS5cPDrqQ/runs/0/artifacts/public/logs/live_backing.log


[task 2022-05-07T01:23:39.772Z] 01:23:39     INFO - TEST-PASS | dom/ipc/tests/browser_domainPolicy.js | Checking script-enabled for root (http://test1.example.org/browser/dom/ipc/tests/file_disableScript.html) - true == true - 
[task 2022-05-07T01:23:39.773Z] 01:23:39     INFO - Console message: [JavaScript Error: "remote browser crashed while on http://mochi.test:8888/browser/dom/ipc/tests/file_domainPolicy_base.html
[task 2022-05-07T01:23:39.773Z] 01:23:39     INFO - " {file: "chrome://mochikit/content/mochitest-e10s-utils.js" line: 10}]
[task 2022-05-07T01:23:39.773Z] 01:23:39     INFO - e10s_init/<@chrome://mochikit/content/mochitest-e10s-utils.js:10:10
[task 2022-05-07T01:23:39.773Z] 01:23:39     INFO - 
[task 2022-05-07T01:23:39.773Z] 01:23:39     INFO - Buffered messages logged at 01:22:54
[task 2022-05-07T01:23:39.773Z] 01:23:39     INFO - Longer timeout required, waiting longer...  Remaining timeouts: 1
[task 2022-05-07T01:23:39.774Z] 01:23:39     INFO - Buffered messages finished
[task 2022-05-07T01:23:39.774Z] 01:23:39     INFO - TEST-UNEXPECTED-FAIL | dom/ipc/tests/browser_domainPolicy.js | Test timed out - 
[task 2022-05-07T01:23:39.775Z] 01:23:39     INFO - GECKO(2790) | MEMORY STAT | vsize 7834MB | residentFast 290MB | heapAllocated 105MB
[task 2022-05-07T01:23:39.775Z] 01:23:39     INFO - TEST-OK | dom/ipc/tests/browser_domainPolicy.js | took 90217ms
[task 2022-05-07T01:23:39.776Z] 01:23:39     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-05-07T01:23:39.776Z] 01:23:39     INFO - TEST-UNEXPECTED-FAIL | dom/ipc/tests/browser_domainPolicy.js | Found a tab after previous test timed out: http://mochi.test:8888/browser/dom/ipc/tests/file_domainPolicy_base.html - 
[task 2022-05-07T01:23:39.776Z] 01:23:39     INFO - checking window state
[task 2022-05-07T01:23:39.777Z] 01:23:39     INFO - TEST-START | dom/ipc/tests/browser_hide_tooltip.js
[task 2022-05-07T01:23:39.777Z] 01:23:39     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-05-07T01:23:39.777Z] 01:23:39     INFO - Buffered messages logged at 01:23:39
[task 2022-05-07T01:23:39.778Z] 01:23:39     INFO - Entering test bound test_hiding_tooltip
[task 2022-05-07T01:23:39.778Z] 01:23:39     INFO - Buffered messages finished
[task 2022-05-07T01:23:39.779Z] 01:23:39     INFO - TEST-UNEXPECTED-FAIL | dom/ipc/tests/browser_domainPolicy.js | Uncaught exception received from previously timed out test - AbortError: Actor 'SpecialPowers' destroyed before query 'Spawn' was resolved
[task 2022-05-07T01:23:39.779Z] 01:23:39     INFO - GECKO(2790) | JavaScript error: chrome://mochikit/content/browser-test.js, line 1052: TypeError: can't access property "shift", currentScope.__tasks is null
[task 2022-05-07T01:23:39.780Z] 01:23:39     INFO - Console message: [JavaScript Error: "TypeError: can't access property "shift", currentScope.__tasks is null" {file: "chrome://mochikit/content/browser-test.js" line: 1052}]
[task 2022-05-07T01:23:39.780Z] 01:23:39     INFO - Console message: [JavaScript Warning: "This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”." {file: "data:text/html,<html title='title'><body>page 1<body></html>" line: 0}]
[task 2022-05-07T01:23:40.315Z] 01:23:40     INFO - TEST-PASS | dom/ipc/tests/browser_hide_tooltip.js | Should have hidden the tooltip - 
[task 2022-05-07T01:23:40.322Z] 01:23:40     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-05-07T01:23:40.323Z] 01:23:40     INFO - TEST-UNEXPECTED-FAIL | dom/ipc/tests/browser_hide_tooltip.js | A promise chain failed to handle a rejection: can't access property "shift", currentScope.__tasks is null - stack: _runTaskBasedTest@chrome://mochikit/content/browser-test.js:1052:13
[task 2022-05-07T01:23:40.323Z] 01:23:40     INFO - Rejection date: Sat May 07 2022 01:23:39 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 271
[task 2022-05-07T01:23:40.323Z] 01:23:40     INFO - Stack trace:
[task 2022-05-07T01:23:40.323Z] 01:23:40     INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:271
[task 2022-05-07T01:23:40.323Z] 01:23:40     INFO - chrome://mochikit/content/browser-test.js:handleTask:1017
[task 2022-05-07T01:23:40.323Z] 01:23:40     INFO - Leaving test bound test_hiding_tooltip
[task 2022-05-07T01:23:40.324Z] 01:23:40     INFO - Console message: [JavaScript Warning: "This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”." {file: "data:text/html,<html><body>page 2</body></html>" line: 0}]
[task 2022-05-07T01:23:40.329Z] 01:23:40     INFO - GECKO(2790) | MEMORY STAT | vsize 7835MB | residentFast 290MB | heapAllocated 107MB
[task 2022-05-07T01:23:40.330Z] 01:23:40     INFO - TEST-OK | dom/ipc/tests/browser_hide_tooltip.js | took 660ms
[task 2022-05-07T01:23:40.338Z] 01:23:40     INFO - checking window state
[task 2022-05-07T01:23:40.340Z] 01:23:40     INFO - TEST-START | dom/ipc/tests/browser_pbrowser_creation_failure.js

Hi Nika, can this be a regression of bug 1767514?

Flags: needinfo?(nika)

Yes, it looks like this was a regression from bug 1767514. Marking as resolved due to the backout of that patch stack.

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(nika)
Resolution: --- → FIXED
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.