Don't re-invent the wheel. Use wget

VERIFIED INVALID

Status

SeaMonkey
Download & File Handling
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: imran.geriskovan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
My suggestion follows:
Please develope download manager as a frontend for a well known
and stable download manager. (such as wget. and it is available on both windozes
and unixes.)

I personally can't use download manager.
If mozilla crashes or if close mozilla for some reason it is impossible to
resume downloads.

Hence, I still use wget on command line copying and pasting the url to it.
I'd love to see Mozilla as a managing gui for wget.

Comment 1

15 years ago
Nope, Resolving Invalid.
You could make this as a add-on for Mozilla (i wouldn't say your idea is bad),
but a DL manager with resume funcrion is already in development. And whats with
the windows people, they don't have wget, what should the do then?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
You are wrong!
I'm now using wget.exe on an windoz machine.
wget is available on all platforms as being a GNU tool.
Shall I reopen the bug?
(Reporter)

Comment 3

15 years ago
+ wget is a single exe with no dependendencies.
It is very handy.
Reopening.. 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

15 years ago
Ok, I've seen this. But this is Mozilla, a add-on, a plugin for wget would be
okay, but to force making Mozilla using wget?!

Comment 5

15 years ago
well, I'll give it a try :-), but I won't think this bug will stay for long...
(Reporter)

Comment 6

15 years ago
This will save mozilla developers from maintaning a downloader/resumer
application. They will only bother with the gui aspects.
Wouldn't it be nice for them?

Comment 7

15 years ago
Might be, but Mozilla is a browser suite and a browser-suite should include all
that: Navigator,Mail&News,HTML-Editor,Adressbook,(IRC-Chat, that could be thrown
out of Mozilla),Downloadmanager

Comment 8

15 years ago
Better look at Bug 92696 I think this one can be duped then
(Reporter)

Comment 9

15 years ago
Well, may be...
But that bug is not considering wget as a download horse.
It only emphasizes that "there should be a link"..
Anyway, I admit that the bugs are closely related.
Bugs can be made dependent to each other.

Now coming to your point:
>Might be, but Mozilla is a browser suite and a browser-suite should include all
>that: Navigator,Mail&News,HTML-Editor,Adressbook,(IRC-Chat, that could be
>thrown out of Mozilla),Downloadmanager

I am not saying "downloadmanager + wget". I'm still talking about
"<b>A</b> downloadmanager". What am I stressing iis this: Use wget at the
background. Users will still a use a "downloadmanager" unaware of the existance
of wget.
Got it?
(Reporter)

Comment 10

15 years ago
Please visit bug 92696.
Summary: "Allow file dowloads to be externalized (eg. to wget)"
You mean, Mozilla should include wget? That would be also a Problem with the
different Open Source licences probably. This is simply getting too complicated.
besides, the only reason the download manager doesn't currently have support  
resuming is because it doesn't have a button for it. Mozilla already supports  
resuming, so there's no need to embed wget or anything silly. All you have to  
do is open the url again, and it should resume automatically. Also, if you  
select a download and hit properties, you'll get an old style download window  
that has a pause/resume button. If you want a download manager that doesn't 
close when you close mozilla, then get one that's a seperate executable. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
V.
lets this bug... ;-)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.