Status

MailNews Core
Composition
--
major
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Steve Notis, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Spellcheck Bug: Without warning or apparent cause, and after months of working
fine, the spellchecker began skipping right to "No Misspelled words found" -
even though there were definitely misspelled words.

I even added more misspellings, and tested several more times, just to be sure.
Then I upgraded from Mozilla v1.2a to v1.2b - and now I get the following
message each time I invoke the spellchecker:

"The procedure entry point ??1nsAVLTree@@QAE@XZ could not be located in the
dynamic link library xpcom.dll."

I checked for xpcom.dll, and it is indeed present in: C:\PROGRAM
FILES\mozilla.org\Mozilla.  
I then completely uninstalled Mozilla and reinstalled v1.2b - but the problem is
unchanged.  

I also noticed that under "Preferences: Appearance, Languages/Content" there are
two messages that say "English (US) (needs update)", and also "US Region (needs
update)".  I tried to update these from the Mozilla web site but was not successful.

I hypothesize that initially the dictionary files may have been deleted, or just
made not accessible to the spellchecker.  But now there must be something in the
registry that's preventing me from doing a clean uninstall/reinstall.

Comment 1

16 years ago
Reporter, try removing the file components/compreg.dat (it will be rebuild).
this can't be a blocker.

This bug is invalid because spellhecker must update to follow the trunk changes
and since spellchecker is a third-party tool -> invalid

BTW: 
Mozilla doesn't use the windows registry (only for System integration)
and
AFAIK there is no updated spellchecker for 1.2x
Severity: blocker → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.