Closed Bug 1769268 Opened 9 months ago Closed 7 months ago

[wayland] Drag and drop tab crashes in dual monitor setup

Categories

(Core :: Widget: Gtk, defect)

Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1775002

People

(Reporter: jhorak, Assigned: jhorak)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

  1. (fedora 36)
  2. have a dualmonitor setup with normal + hidpi scaling
  3. start drag of the tab on monitor with normal dpi
  4. immediate crash

This seems to be because the wl_surface expect the buffer be in 2 scale factor for some reason.

Blocks: wayland
OS: Unspecified → Linux
Hardware: Unspecified → Desktop
See Also: → 1767916

The fix eliminates the issue partially only, it's not complete remedy. This seems to be a problem of mutter:
This seems to be related: https://gitlab.gnome.org/GNOME/mutter/-/issues/2163

Turns out to be a bug in mutter compositor.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

We need to fix that at some point so closing as dupe of Bug 1775002 which has more relevant info.

Status: REOPENED → RESOLVED
Closed: 8 months ago7 months ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.