Xprint module missing on AIX

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: art_vedas, Assigned: hhoetzel)

Tracking

Trunk
Other
Other
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0

I do not get any XPrint driver printers listed in the print window with AIX Mozilla.

Reproducible: Always

Steps to Reproduce:
1. configure XPrint server like on Linux/Solaris
2. run XPrint server
3. set XPSERVERLIST var to XPrint server
4. start mozilla
5. open print window
Actual Results:  
No printers except Postscript/default.

Expected Results:  
Lots of printers for the XPrint driver.

Comment 1

16 years ago
Mhhh, there is no components/libgfxxprint.so in that distribution, but it is not
a RPM build (that would be bug 133534 ("Xprint support not available in RPM
builds")).

I guess the AIX version used to build the distribution misses libXp.a (which is
a requirement for building the Xprint module).

----

Over to "build config" for now.

----

cls:
Who build the AIX release ?
Assignee: katakai → seawood
Status: UNCONFIRMED → NEW
Component: Printing: Xprint → Build Config
Ever confirmed: true
QA Contact: Roland.Mainz → granrose

Updated

16 years ago
Summary: XPrint driver printers missing on AIX → Xprint module missing on AIX
(Assignee)

Comment 2

16 years ago
This is the AIX Netscape 7 built by IBM. 
The Xprint Xserver extension was added to AIX 5.2 which was just released.
There are still some problems with Xprint in AIX Mozilla/Netscape 7 and we ran
out of time to fix them. Therefore, it is not enabled yet. It is something we
need to work on now. Once it is solved, Xprint can be enabled in both, Mozilla
and Netscape 7.
I will update this defect with the current status because I think we need some
help from Roland to figure out what's wrong :-)  

Comment 3

16 years ago
Mary Hoetzel wrote:
> This is the AIX Netscape 7 built by IBM. 
> The Xprint Xserver extension was added to AIX 5.2 which was just released.
> There are still some problems with Xprint in AIX Mozilla/Netscape 7 and we ran
> out of time to fix them. Therefore, it is not enabled yet.

AFAIK the problems are all at the server side, right ?
This bug report is only related to the client-side (Mozilla); AFAIK the client
side X11 extension library libXp.so/.a is bug-free (assuming you're using
X11R6.6 :) - therefore it won't hurt to enable it now (users could use an Xprt
build from the http://xprint.mozdev.org/ sources (Xprt itself seems to
build&work on AIX, too), use an existing Linux/Solaris Xprt for now) or use a
Xprt server remotely.

Remember that fixes/enhanchements to Xprt (Xprint server-side) automagically
"upgrade" all applications which use it (e.g. existing Mozilla1.0 binaries can
print with Truetype fonts when Xprt gets upgraded etc.), so even if your AIX
Xprt server it buggy the client-side apps. does not have to worry about it (e.g.
development of client and server side is independent).

What about dropping-in libXp.a on AIX (e.g. link libXp.a statically or ship the
library with the Mozilla distribition) and rebuilding the release tarball ?
We need a separate component for distribution issues.  Back to XPrint.
Assignee: seawood → katakai
Component: Build Config → Printing: Xprint
QA Contact: granrose → Roland.Mainz
(Assignee)

Comment 5

16 years ago
The upcoming Mozilla 1.2 for AIX will be statically linked with libXp.a.  

Comment 6

16 years ago
Mary Hoetzel wrote:
> The upcoming Mozilla 1.2 for AIX will be statically linked with libXp.a.

What about marking the client-side library libXp.a available on older AIX
releases, too (AFAIK it can't hurt - the library is small and don't affect
anything except Xprint :) ?

Updated

16 years ago
Depends on: 183093

Comment 7

16 years ago
Reassigning bug to Mary Hoetzel from IBM...
Assignee: katakai → hhoetzel

Comment 8

16 years ago
Note that I filed bug 183093 ("Add "configure"-option to link libXp statically
(e.g. libXp.a instead of libXp.so)") to get a general-purpose build flag for
such cases...

Comment 9

16 years ago
Has there been any progress on this bug?
(Assignee)

Comment 10

16 years ago
Mozilla 1.3b for AIX that's now available has been statically linked with
libXp.a. This is a temporary solution until we have figured out how to provide
libXp.a separately.
Not sure what I should do with this defect now. Should it stay open until
libXp.a is available? Making libXp.a available is not really a Mozilla bug.

Updated

16 years ago
Depends on: 196349
This is not blocking development.
severity -> major
Severity: blocker → major
Product: Core → Core Graveyard

Comment 12

9 years ago
XPrint support is gone.  See bug 326716.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.