Link Crashing [@ nsGfxScrollFrame::Destroy ]

RESOLVED WORKSFORME

Status

()

Core
Layout: HTML Frames
P2
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Jonathan Nellis, Assigned: John Keiser (jkeiser))

Tracking

({crash})

Trunk
Future
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
Mozilla 1.2b (build 20021016) crashes on my WinXP SP 1 pc 100% of the times I
click a certain image link.

Steps to reproduce:
1. Load the Mozilla browser
2. Visit the site http://www.inuyasha.com/
3. Click the upper left image link in the top frame
4. Watch as browser instantly crashes

System Crash is Occuring On:
Windows XP Professional Service Pack 1
Pentium 4 1900MHz, 512Mb 800MHz RDRAM, 1024x768 32bit
Mozilla build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b)
Gecko/20021016

Talkback Incident ID: TB13132049G

Comment 1

15 years ago
WFM build 2002102208 on Mac OS 9

Comment 2

15 years ago
wfm using Phoenix 20021026 on Win2k.
Severity: normal → critical
Keywords: crash, stackwanted
Whiteboard: TB13132049G
(Reporter)

Comment 3

15 years ago
After some more tests I realized that this crash occurs on my system after I 
leave this site in multiple ways (clicking a link, pushing the browser back 
button, typing a new url in the address bar and pushing enter).
(Reporter)

Comment 4

15 years ago
One final note, I just downloaded the nightly build 20021026 and am still having
this crash occur.

Comment 5

15 years ago
WFM on LINUX

Mozilla 1.2b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Comment 6

15 years ago
wfm xp pro sp1 moz 2002102508

Comment 7

15 years ago
OS : Linux 2.4.17 Mozilla 1.2b 2002101612

http://shoutcast.com
press "Tune In".
Mozilla hangs.
Works on Mozilla 1.2a

Comment 8

15 years ago
Can not reproduce it everytime.

Comment 9

15 years ago
WFM with build 20021026 on W2K.
(Reporter)

Comment 10

15 years ago
Just a few extra details incase no one else can reproduce this crash.  I put 
up a few screenshots of some visual effects this bug causes and a copy of the 
section of html code that appears to be causing the crash on the site 
http://home.adelphia.net/~jnellis/possiblebugs/

Comment 11

15 years ago
Unable to reproduce from either the original site or the testcase.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
*Incident ID:  *   
Incident ID 13132049
Stack Signature 0x01beace5 c2ea1e4c
Product ID MozillaTrunk
Build ID 2002101612
Trigger Time 2002-10-26 22:50:18
Platform Win32
Operating System Windows NT 5.1 build 2600
Module
URL visited http://www.inuyasha.com/
User Comments Every time i click the top right most image/button link in the 
upper frame (of 2 frames) the browser crashes.
Trigger Reason Illegal instruction
Source File Name
Trigger Line No.
Stack Trace

0x01beace5
nsGfxScrollFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 465]
nsFrameList::DestroyFrames 
[c:/builds/seamonkey/mozilla/layout/base/src/nsFrameList.cpp, line 131]
nsContainerFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 143]
nsBoxFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1115]
nsTextControlFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsTextControlFrame.cpp, line 
1439]
nsFrameList::DestroyFrames 
[c:/builds/seamonkey/mozilla/layout/base/src/nsFrameList.cpp, line 131]
nsContainerFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 143]
nsFrameList::DestroyFrames 
[c:/builds/seamonkey/mozilla/layout/base/src/nsFrameList.cpp, line 131]
nsContainerFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 143]
nsLineBox::DeleteLineList 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineBox.cpp, line 312]
nsBlockFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 423]
nsLineBox::DeleteLineList 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineBox.cpp, line 312]
nsBlockFrame::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 423]
nsLineBox::DeleteLineList 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineBox.cpp, line 312]
DestroyOverflowLines 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 4746]
DestroyPropertyEnumerator 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsFrameManager.cpp, line 2689]
PL_DHashTableEnumerate [c:/builds/seamonkey/mozilla/xpcom/ds/pldhash.c, line 602]
FrameManager::PropertyList::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsFrameManager.cpp, line 2699]
FrameManager::DestroyPropertyList 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsFrameManager.cpp, line 2394]
FrameManager::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsFrameManager.cpp, line 526]
PresShell::Destroy 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 1851]
DocumentViewerImpl::Destroy 
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 1157]
DocumentViewerImpl::Show 
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 1390]
PresShell::UnsuppressAndInvalidate 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 4880]
PresShell::UnsuppressPainting 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 4927]
PresShell::sPaintSuppressionCallback 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 2921]
nsTimerImpl::Fire [c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp, 
line 368]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 645]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, 
line 578]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 
1336]
USER32.dll + 0x3d91 (0x77d43d91)
USER32.dll + 0x438c (0x77d4438c)
nsAppShellService::Run 
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1538]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1886]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1906]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7)

-> Layout
Assignee: asa → frame
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: HTML Frames
Ever confirmed: true
Keywords: stackwanted
QA Contact: asa → amar
Whiteboard: TB13132049G
(Reporter)

Comment 13

15 years ago
I noticed you change the component to frames.  I just wanted to make sure you 
were aware that this crash does occur for me even when I visit the html file 
that makes up the bottom frame alone (http://www.inuyasya.com/main.shtml) 
without loading the frames page (http://www.inuyasya.com/index.shtml).  

Another note: The scrolling marquee or related scripts in the main.shtml file 
may be related because one time I visited the page and the marquee did not 
load for some reason or another, the crash did not occur.

Updated

15 years ago
Priority: -- → P2

Updated

15 years ago
Summary: Link Crashing Mozilla 1.2b → Link Crashing Mozilla 1.2b [@ nsGfxScrollFrame::Destroy ]
Summary: Link Crashing Mozilla 1.2b [@ nsGfxScrollFrame::Destroy ] → Link Crashing [@ nsGfxScrollFrame::Destroy ]

Comment 14

15 years ago
similar stack with bug 134481 but different component.
-> jkeiser
Assignee: frame → jkeiser
Target Milestone: --- → Future
WFM, Mozilla 1.5 and 2003-10-18-05 trunk Linux

Comment 17

14 years ago
worksforme with 2004021709 seamonkey build on winXP.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsGfxScrollFrame::Destroy ]
You need to log in before you can comment on or make changes to this bug.