Closed Bug 1769740 Opened 5 months ago Closed 4 months ago

Unnecessary Facebook banner is present when accepting the "Cookie Policy" at expertflyer.com with ETP set to STRICT

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 102
Other
Android
defect

Tracking

()

VERIFIED FIXED
103 Branch
Tracking Status
firefox102 --- wontfix
firefox103 --- fixed

People

(Reporter: raul.bucata, Assigned: twisniewski)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Attached image Screenshot_33.png

Environment:
Operating system: Android 11/ Android 12
Firefox version: Firefox Nightly 102.0a1 (2015880747 -🦎102.0a1-20220513093538🦎)

Preconditions:
ETP set to STRICT
Clean profile

Steps to reproduce:

  1. Navigate to: https://www.expertflyer.com/mobile/login.do.
  2. Accept the "Cookie Policy" pop-up.
  3. Observe the result.

Expected Behavior:
The login form loads as expected.

Actual Behavior:
The login form presents an unnecessary Facebook banner.

Notes:

  • Not reproducible with ETP set to STANDARD.
  • Works as expected using Chrome.
  • Screenshot is attached.
Severity: -- → S3
Priority: -- → P3

This looks like SmartBlock adding an extra, duplicate button when it doesn't have to (presumably because the site is using very old code which SmartBlock doesn't work properly with). I'll take a look at this ASAP.

Based on FB's code, we just need to check if a given login button has any textContent before adding our own button, and if so, just leave it alone.

Blocks: 1773100
Assignee: nobody → twisniewski
Status: NEW → ASSIGNED
Pushed by twisniewski@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/774256e8b6a5
have the SmartBlock Facebook SDK shim not provide a 'log in with Facebook' button if the placeholder has textContent already, to prevent multiple buttons from appearing; r=ksenia,webcompat-reviewers
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

The patch landed in nightly and beta is affected.
:twisniewski, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(twisniewski)
Flags: needinfo?(twisniewski)

I can confirm this is fixed, the page loads correctly now.
https://prnt.sc/lF3xxCJgYfWC

Tested with:
Browser / Version: Firefox Nightly 105.0a1 (🦎 105.0a1-20220816095503)
Operating System: Google Pixel 5 (Android 12) - 1080 x 2340 pixels, 19.5:9 ratio (~432 ppi density), Samsung Galaxy S8 (Android 9) - 1440 x 2960 pixels, 18.5:9 ratio (~570 ppi density)

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.