If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Missing files in dist area

VERIFIED FIXED

Status

()

Core
Layout
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Colin Blake, Assigned: buster)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
After I finish an M11 build, my dist area is missing some files. In
dist/bin/res/html there are a bunch of links to files that exist in
mozilla/layout/html/base/src. Only the first file, broken-image.gif
has its link correct; all the rest are wrong. Here's an ls -l:

m11dbg> pwd
/m11dbg/layout/html/base/src
m11dbg> ls -l /m11dbg/dist/bin/res/html
total 0
lrwxrwxrwx   1 system   system        50 Oct 29 11:09 broken-image.gif -> /m11/m
ozilla/layout/html/base/src/broken-image.gif
lrwxrwxrwx   1 system   system        47 Oct 29 11:09 empty_doc.html -> ../../..
/../layout/html/base/src/empty_doc.html
lrwxrwxrwx   1 system   system        49 Oct 29 11:09 gopher-audio.gif -> ../../
../../layout/html/base/src/gopher-audio.gif
lrwxrwxrwx   1 system   system        50 Oct 29 11:09 gopher-binary.gif -> ../..
/../../layout/html/base/src/gopher-binary.gif
lrwxrwxrwx   1 system   system        48 Oct 29 11:09 gopher-find.gif -> ../../.
./../layout/html/base/src/gopher-find.gif
lrwxrwxrwx   1 system   system        49 Oct 29 11:09 gopher-image.gif -> ../../
../../layout/html/base/src/gopher-image.gif
lrwxrwxrwx   1 system   system        48 Oct 29 11:09 gopher-menu.gif -> ../../.
./../layout/html/base/src/gopher-menu.gif
lrwxrwxrwx   1 system   system        49 Oct 29 11:09 gopher-movie.gif -> ../../
../../layout/html/base/src/gopher-movie.gif
lrwxrwxrwx   1 system   system        50 Oct 29 11:09 gopher-telnet.gif -> ../..
/../../layout/html/base/src/gopher-telnet.gif
lrwxrwxrwx   1 system   system        48 Oct 29 11:09 gopher-text.gif -> ../../.
./../layout/html/base/src/gopher-text.gif
lrwxrwxrwx   1 system   system        51 Oct 29 11:09 gopher-unknown.gif -> ../.
./../../layout/html/base/src/gopher-unknown.gif
m11dbg>

My source tree is /m11 and my build tree is /m11dbg. You'll see that the
first file has the correct (absolute) link to get from the build tree to
the source tree. The remainder of the files are have relative links that
stay within the build tree - the gif files are not in the build tree they
are in the source tree.

The problem is in the Makefile source/layout/html/base/src/Makefile.in
It does this:

  $(INSTALL) $(srcdir)/$(RESOURCES) $(DIST)/bin/res/html

So only the first RESOURCE file is fully qualified.

I believe the fix is to prepend $(srcdir) to each $(RESOURCE).

Colin.

Updated

18 years ago
Assignee: troy → kipp

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 1

18 years ago
I have been assigned as QA contact but not sure how to check this fix.
(Reporter)

Comment 2

18 years ago
I can vouch for the fact that this problem is fixed. If everything else is in
order, please close the report.
You need to log in before you can comment on or make changes to this bug.