If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to save file under Mozilla 20021016

RESOLVED DUPLICATE of bug 171441

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 171441
15 years ago
13 years ago

People

(Reporter: kclaw, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Dear Sir,

I found that we had difficulty to save the individual object of the web page on 
this situation. Suppose that a web page contained several image files and a 
number of links that refereed to some media file, for example zip, jpg, gif, 
wmv, mp3, etc. If we tried to save them, a saving dialog would be showed for 
feeding back the file name and the location to be stored. When people completed 
the process and checked it, we could not find the file in the destination.

However, if we saved the whole page or an individual frame, it worked fine, at 
least all the image files could be saved.

Regards,

Dennis

Updated

15 years ago
Whiteboard: DUPEME

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 171441 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v.
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
He, are you sure?
" that refereed to some media file, for example zip, jpg, gif, 
wmv, mp3, etc. If we tried to save them, a saving dialog would be showed for 
feeding back the file name and the location to be stored. When people completed 
the process and checked it, we could not find the file in the destination.

However, if we saved the whole page or an individual frame, it worked fine, at 
least all the image files could be saved."

This is an dupe, but not of Bug 171441
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

15 years ago
Bug 162271, maybe?

Comment 5

15 years ago
Reporter (kclaw), can you find the downloaded files in the temporary
directory (c:windows\temp\)?
(Reporter)

Comment 6

15 years ago
I cannot find any new file in the temporary directory (c:windows\temp\).

Comment 7

15 years ago
Reporter (kclaw), what's your browser build ID and OS?

How is the bug reproduced? By following a download link or by choosing "Save
image as" from context (right-click) menu?

Can you reproduce this bug with a new profile?

And please post the "downloads.rdf" file found in your profile
directory as an attachment
(Reporter)

Comment 8

15 years ago
For your reference.

Build Identifier:
Mozilla 1.2b
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016

Steps to Reproduce:
1, Go to http://www.lo-mac.com/movies.php
2, Download the quick time movie, that located in the center of the page. Right
click the link, and select “Save Link Target As …”. A Save As Dialog Box appear
then I save the “lockOnWeb2.mov” to drive c:\. Then Download Manager appears and
shows the progress.
3, Save the snap shot of the pilot view located in the center of the same page.
Right click the image file, and select “Save Link Target As …”. A Save As Dialog
Box appear then I save the “movie_1.jpg” to drive c:\. Then Download Manager
appears and shows the progress.

Result:
The two files did not exist in my drive c:\. And I have searched all my local
drive, also the cache folder of the Mozilla, but no file sized 4M bytes could be
found.

Here is the content of my downloads.rdf file:

<?xml version="1.0"?>
<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"
         xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
  <RDF:Seq about="NC:DownloadsRoot">
    <RDF:li resource="C:\LockOnWeb2.mov"/>
    <RDF:li resource="C:\movie_1.jpg"/>
    <RDF:li resource="C:\mozilla-win32-1.2a-installer.exe"/>
  </RDF:Seq>
  <RDF:Description about="C:\LockOnWeb2.mov"
                   NC:Name="LockOnWeb2.mov"
                   NC:ProgressMode="none"
                   NC:StatusText="Finished"
                   NC:Transferred="4172KB of 4172KB">
    <NC:URL resource="ftp://ftp.ubisoft.com/games/lomac/media/LockOnWeb2.mov"/>
    <NC:File resource="C:\LockOnWeb2.mov"/>
    <NC:DownloadState NC:parseType="Integer">1</NC:DownloadState>
    <NC:ProgressPercent NC:parseType="Integer">100</NC:ProgressPercent>
  </RDF:Description>
  <RDF:Description about="C:\movie_1.jpg"
                   NC:Name="movie_1.jpg"
                   NC:ProgressMode="none"
                   NC:StatusText="Finished"
                   NC:Transferred="1KB of  1KB">
    <NC:URL resource="http://www.lo-mac.com/images/movie_1.jpg"/>
    <NC:File resource="C:\movie_1.jpg"/>
    <NC:DownloadState NC:parseType="Integer">1</NC:DownloadState>
    <NC:ProgressPercent NC:parseType="Integer">100</NC:ProgressPercent>
  </RDF:Description>
</RDF:RDF>

Comment 9

15 years ago
This is probably dupe of bug 171441 which was resolved as fixed
in 2002-10-24 (bug 171441 comment 236). Resolve as dupe for now.

Reporter, please download a newer nightly build and see if you
can reproduce the problem. Reopen this bug if problem still persists.

*** This bug has been marked as a duplicate of 171441 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Summary: Unable to save file under Mozilla 1.2b → Unable to save file under Mozilla 20021016
Whiteboard: DUPEME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.