[ABS POS] Switching from position fixed to position absolute no longer works

RESOLVED DUPLICATE of bug 176926

Status

()

RESOLVED DUPLICATE of bug 176926
16 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: dbaron)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In Mozilla build 2002102704, changing from position absolute to position fixed
will succeed. But changing from position fixed to position absolute will NOT
succeed. There is no problem in build 20021023, in Phoenix 0.3 and in NS 7 final
release. This is a recent regression for sure.

I'm not sure if this could be related to a new [regression] bug related to
changing the src attribute value of an image.

Self-explanatory testcase following.
(Reporter)

Comment 1

16 years ago
Created attachment 104338 [details]
Self-explanatory testcase


This bug could be related to another bug regarding [image] rollover effect. I
am not sure.

Instructions and expected results:
 * Click the push pin image. Scroll down the page. The image should be fixed in
the viewport.
  * click the push pin image again. Scroll up the page. The image should be
absolutely positioned.

Actual results in build 2002102704:
The src attribute of the pushpin image is not changed. The position is changed
from position absolute to fixed but from position:fixed it seems not possible
to  change back to position:absolute.
(Reporter)

Updated

16 years ago
Keywords: regression, testcase
I bet this is a dup of that .src regression that bryner's about to fix....

Comment 3

16 years ago
I am not able to see thr pushpin image in the testcase attachment 104338 [details]
(Reporter)

Comment 4

16 years ago
Madhur, I cannot see, use the pushpin image either: I'm very much inclined to
believe that this bug is in fact bug 176926 really.
(Reporter)

Comment 5

16 years ago
The src of the image is never loaded. The switching from position:absolute (or
fixed) to position:fixed (or absolute) works well with the alternate text. So,
this has to be a duplicate bug of 176926. Everything kinda suggest it is the case.

Sorry for those who spent time over this bug.

*** This bug has been marked as a duplicate of 176926 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.