Browser crashes on startup with error about FcPatternReference

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Allen Baranov, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I am using mozilla 1.2. I have tried this with beta and a couple of nightlies
with no luck. I am running the xft version. The rpm installs perfectly but on
start-up from inside the directory with ./run-mozilla.sh when the script runs
./mozilla-bin it crashes with 

./mozilla-bin: relocation error: /usr/lib/mozilla-1.2b/components/libgfx_gtk.so:
undefined symbol: FcPatternReference

I have a very customized Linux box which is loosly based on redhat 8. Some rpms
are newer and some older. As I said before though, the rpm installs fine. 

This happens with gdkxft preloaded in X and with it not preloaded. Other gtk
based software works fine and is rendered correctly.

Updated

15 years ago
Keywords: crash

Comment 1

15 years ago
> start-up from inside the directory with ./run-mozilla.sh when the script runs

don't do that.  run /usr/bin/mozilla
I don't know if that will fix anything or not, but it's worth a shot.  Have you
tried a standard (non-xft) build?  Have you tried a non-rpm build?
(Reporter)

Comment 2

15 years ago
I have tried with /usr/bin/mozilla which does nothing. I started it up as a new
user and it created the .mozilla directories but then just hung. 

I have an older version of the software which works fine (what I am typing this
on) but I'm interested in the xft version of 1.2b. 

And...no..I trust rpms and I use them almost exclusively on my box and
especially for something like mozilla that is big. 

Comment 3

15 years ago
does it still happen using latest nightly build ?
http://ftp.mozilla.org/pub/mozilla/nightly/latest

Comment 4

15 years ago
Resolving due to lack of response from reporter

please reopen if the problem persists with a new build of Mozilla
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.