Closed Bug 177083 Opened 17 years ago Closed 17 years ago

Mozilla does not start on Windows 95

Categories

(SeaMonkey :: UI Design, defect, blocker)

x86
Windows 95
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: torben, Assigned: aaronlev)

References

Details

(Keywords: smoketest)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20021024
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla/nightly/2002-10-25-04-trunk

Mozilla builds 2002102504 and newer do not start on windows 95. You get the
splash screen and then nothing - no select profile dialog, no browser window.
Starting with a specified profile (-P profile) does not work either. Tested
builds with this error are 2002102504, 2002102508, 20002102704 (all trunk).
Latest working build is 2002102415.
All builds were downloaded as the talkback-zip files, unzipped in to new
directories.

Reproducible: Always

Steps to Reproduce:
1. Install mozilla build 2002102504-trunk or newer on win 95
2. Start mozilla


Actual Results:  
Splash screen shows up, then nada.

Expected Results:  
Mozilla should start.

This is not a dupe of Bug 170969 (see bug 170969 comment 26)
Severity: critical → blocker
Keywords: smoketest
I noticed that the newest Phoenix built 2002-10-28-08-trunk loads the IE dll
"shfolder.dll" during start-up on my win95 machine.  Why is Phoenix/Mozilla
using IE dlls?
setting bug status to New. Mozilla and Phoenix builds fail to start on win95.
This seems to have been introduced on 10/24 (last known working build was on the
23rd). This is a serious regression and needs to be tracked down. 
Assignee: asa → sgehani
Blocks: 1.2
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: asa → paw
" OK, I rebooted from my beautiful Linux desktop into Win95, version 4.00.950
retail copy, and pulled down the latest Phoenix build. It does not start, as
described on the mozillaZine front page. I copied all the EXE and DLL files into
one directory and opened them with the Dependency Walker
(http://www.dependencywalker.com/) and it showed that gkwidget.dll was importing
a function called GetGUIThreadInfo from user32.dll which does not exist in my
Win95 version of the DLL.

I replaced the bad version of gkwindget.dll with the copy from the 10/21 build
and Phoenix started fine.

MSDN shows "Minimum operating systems: Included in Windows 98, Windows NT 4.0
SP3" for GetGUIThreadInfo().

I apologize for posting only here. I do not have a Bugzilla account."
aaronl made changes to widget around the date this began failing. Aaron, does
this look like something you could have broken?
I'm using GetGuiThreadInfo to get the currently focused window, according to
what MS Windows says it is. If there's another better way to do this I could use
that.
Assignee: sgehani → aaronl
I think I might be able to use this instead:
HWND GetForegroundWindow(VOID);
It's available on win95 and nt 3.1
Seeking r=/sr=

Asa gave verbal a= over IRC
Comment on attachment 104609 [details] [diff] [review]
Use dll instead of static library method, for GetGUIThreadInfo

r=kyle
Attachment #104609 - Flags: review+
Comment on attachment 104609 [details] [diff] [review]
Use dll instead of static library method, for GetGUIThreadInfo

a=asa on IRC
Attachment #104609 - Flags: approval+
Comment on attachment 104609 [details] [diff] [review]
Use dll instead of static library method, for GetGUIThreadInfo

sr=alecf
Attachment #104609 - Flags: superreview+
Saw asa asking for data-points from W95 users--looks like the need is past, but ....

win95 4.00.950 C
Pentium 350 mhz
64 mb ram

2002102415 was the last working build, spot-checked through 2002103010
w/no joy found.

HTH.
checked in
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Problem gone in build 2002103110. Veryfing.
Status: RESOLVED → VERIFIED
*** Bug 178156 has been marked as a duplicate of this bug. ***
*** Bug 181832 has been marked as a duplicate of this bug. ***
*** Bug 183098 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.