Closed Bug 1770968 Opened 1 month ago Closed 1 month ago

Pinned tabs are not correctly handled when the number of normal tabs overflows

Categories

(Firefox :: Theme, defect)

Firefox 102
defect

Tracking

()

RESOLVED FIXED
102 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox100 --- unaffected
firefox101 --- unaffected
firefox102 --- fixed

People

(Reporter: dlrobertson, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Steps to Reproduce:

  • pin at least two tabs
  • click new tab until the tabs overflow

Expected behavior:

  • pinned tabs stay in place and normal tabs overflow

Actual results:

  • pinned tabs are shown under the close/expand/minimize buttons

This can also be reproduced with the following:

  • click new tab until the tabs overflow
  • create two new tabs and pin them

I've tested on Mac, but have not tested any other platforms.

First noticed on: 102.0a1 (2022-05-24) (64-bit)

Component: XUL → Theme
Product: Core → Firefox

[Tracking Requested - why for this release]: This makes Firefox pretty unusable for me.

I'm also on OSX. A workaround is to maximize the window and then the weird flickering stops.

Flags: needinfo?(dao+bmo)
Keywords: regression
Regressed by: 1770808

For me, the resulting behavior is worse than described in comment 0. I have 12 pinned tabs and a dozen regular tabs. Basically whenever I move the mouse the entire tab bar completely freaks out, like it is rapidly recalculating the entire tab bar.

Set release status flags based on info from the regressing bug 1770808

Ok, it looks like maximizing the window doesn't actually fix the issue per se. It just made the window wide enough that all of the tabs could fit in the window. I opened a few more tabs and then it started happening while maximized.

Regressor was backed out from central, new desktop nightlies incoming: https://bugzilla.mozilla.org/show_bug.cgi?id=1770808#c5

Aryx wasn't able to reproduce in Windows 8.1. Maybe it is OSX specific?

(In reply to Andrew McCreight [:mccr8] from comment #3)

For me, the resulting behavior is worse than described in comment 0. I have 12 pinned tabs and a dozen regular tabs. Basically whenever I move the mouse the entire tab bar completely freaks out, like it is rapidly recalculating the entire tab bar.

I am also able to reproduce this with ~6 pinned tabs

Another report of this from somebody on the MoCo slack, also on OSX.

The original patch was backed out and a fixed version relanded. Can you confirm this is fixed for you on tomorrow morning's nightly, and close this out as WFM if so?

Flags: needinfo?(dao+bmo) → needinfo?(drobertson)
Status: NEW → RESOLVED
Closed: 1 month ago
Flags: needinfo?(drobertson)
Resolution: --- → WORKSFORME

+1 Thanks!

Resolution: WORKSFORME → FIXED
Target Milestone: --- → 102 Branch
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.