Closed Bug 1771530 Opened 6 months ago Closed 1 month ago

After updating to Firefox 100.0.2 launching the app causes a delay in accessing sites due to 8x iterations running. WIN7 with current updates checking with Task Manager. Seems to create additional instances when other tabs are created..

Categories

(Core :: Performance, defect)

Firefox 100
x86_64
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gsharp1951, Unassigned)

Details

Attachments

(1 file)

Attached image FF_multi-instance.JPG

Steps to reproduce:

Just launching Firefox creates multiple copies.

Actual results:

Accessing a site or page creates addition instances. Firefox is launched thru a desktop shortcut. Previously there was no issue.

Expected results:

Response time should not be impacted. Takes ~10 seconds for the new page to come up. Usually is fairly quickly, ~couple of seconds.

Component: Untriaged → Performance
OS: Unspecified → Windows 7
Product: Firefox → Core
Hardware: Unspecified → x86_64

Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables add-ons, extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems.) See https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
And does this also happen with a new and empty profile? See https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems#w_6-create-a-new-firefox-profile

Flags: needinfo?(gsharp1951)

When selecting Mozilla Trouble Shooting Mode, the number of Firefox Processes is reduced to 5x from 8x. Only other application launched is Thunderbird. Restarting Firefox after closing with Trouble Shooting Mode, relaunching Firefox goes back to 8x Processes.
Hope this helps!

Flags: needinfo?(gsharp1951)

The multiple processes are normal and expected. The long time to load a new page is not, please include a profile of this occurring, see the following documentation: https://profiler.firefox.com/docs/#/./guide-startup-shutdown

Flags: needinfo?(gsharp1951)

Now utilizing version 104.0.1 and the instances of Firebox.exe are similar, the delay when accessing additional New Tabs is no longer seen. Anywhere from 8-10 instances are seen in the Process window of Windows Task Manager, which increases to 9 or 11 when starting a New Tab. A residual Process is left occasionally after closing the New Tab. But the 'slowness' is not seen as before.
Thank you and All for their Diligence in this matter!
Guy
244,22

Flags: needinfo?(gsharp1951)

Thank you, please reopen this bug if the problem reoccurs.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.