Closed Bug 1771613 Opened 4 months ago Closed 3 months ago

[NVIDIA] Firefox freezes on window event when using Wayland with Nvidia graphics

Categories

(Core :: Graphics, defect)

Firefox 100
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: 0fwv42r5o, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached video Video of the bug

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:100.0) Gecko/20100101 Firefox/100.0

Steps to reproduce:

  1. I'm using Fedora Workstation 36 with Nvidia proprietary graphics 510.68.02. Wayland is now the default display server with Nvidia.
  2. Run Firefox on a Wayland session.
  3. Open a new Firefox window, or switch to another existing window using Alt+Tab.

Actual results:

The new window or the window you switched to will be frozen until you manipulate it in some way, like dragging it or opening the GNOME activities (see video).

Expected results:

The windows should have worked normally without freezing.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Component: Widget: Gtk → Graphics

0fwv42r5o, is this a regression?

Flags: needinfo?(0fwv42r5o)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #2)

0fwv42r5o, is this a regression?

I don't know, Firefox has always behaved like that on Wayland for me every time I tested, which is why I'm still using Xorg.

Unfortunately I don't have NV hardware to test that. Looks like we're missing some kind of expose or so.

Blocks: wayland

It's worth mentioning that this bug only happens when Firefox is maximized. If it's a non-maximized window, it does not freeze.

Also, if hardware WebRender is disabled, the bug does not happen. But for performance, it's better to use Xorg for now.

Summary: Firefox freezes on window event when using Wayland with Nvidia graphics → [NVIDIA] Firefox freezes on window event when using Wayland with Nvidia graphics

After upgrading to NVIDIA driver 515.57, this bug no longer happens.

(In reply to 0fwv42r5o from comment #7)

After upgrading to NVIDIA driver 515.57, this bug no longer happens.

Thanks, so apparently just a driver bug.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.