Closed Bug 1771700 Opened 1 month ago Closed 29 days ago

primary password dialog doesn't use dark mode colors

Categories

(Thunderbird :: Theme, defect)

defect

Tracking

(thunderbird_esr91 unaffected, thunderbird102? fixed, thunderbird103 affected)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird102 ? fixed
thunderbird103 --- affected

People

(Reporter: Thunderbird_Mail_DE, Assigned: Paenglab)

Details

Attachments

(3 files)

Thunderbird Daily 2022-05-29 build

The main password dialog is still using light colors in dark mode:

Summary: Main password dialog doesn't use dark mode colors → primary password dialog doesn't use dark mode colors

The wiered thing: This "defect" is only, for the very first primary password dialog, when starting Thunderbird. If you click "Cancel" and the next primary password dialog pops up, it has a dark background as expected.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED

The problem is that when this dialog is shown on startup, TB isn't loaded and thus it doesn't know

Target Milestone: --- → 103 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c15ecbeb724f
Remove on commonDialog.xhtml the lightweightthemes="true" to let it adapt the theme colors on startup. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED

Comment on attachment 9279622 [details]
Bug 1771700 - Remove on commonDialog.xhtml the lightweightthemes="true" to let it adapt the theme colors on startup. r=aleca

[Approval Request Comment]
User impact if declined: inconsistent dialog colours on startup
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9279622 - Flags: approval-comm-beta?

Comment on attachment 9279622 [details]
Bug 1771700 - Remove on commonDialog.xhtml the lightweightthemes="true" to let it adapt the theme colors on startup. r=aleca

[Triage Comment]
Approved for beta

Attachment #9279622 - Flags: approval-comm-beta? → approval-comm-beta+

just updated to 102.0b3 and am having this problem. Had not actually seen it before 102.0b3.

You need to log in before you can comment on or make changes to this bug.