file input does not work

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P2
normal
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Jeremy Layne Weathers, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I've tested this on both Windows 2000 and Mac OS X 10.2. For Mozilla 1.1 and
Phoenix 0.3, the file input does not work (perhaps only when it is styled?).
Clicking the 'Browse...' button causes it to disappear. Entering the path to the
file and submitting did not work at all on Mac OS X - on Windows 2000, it did
work if the 'Browse...' button was not clicked. The problem does not appear on
Chimera 0.5.
Please attach a testcase _especially_ if you're styling the control.

Updated

16 years ago
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 2

16 years ago
I've posted a copy of the faulty form at
<http://cobweb.nwark.com/~layne/upload.html>

As soon as I isolate the relavent styles I will upload a testcase page.
Created attachment 106592 [details]
testcase

This happens when the width set is too small for the control (and the table
does need to be there, so something is shrink-wrapping it).
to layout
Assignee: alexsavulov → form
Status: UNCONFIRMED → NEW
Component: Form Submission → Layout: Form Controls
Ever confirmed: true
Priority: P4 → --
QA Contact: vladimire → tpreston
Target Milestone: Future → ---

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future

Updated

16 years ago
Keywords: testcase

Comment 6

16 years ago
Reproduced using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-CA; rv:1.0.2)
Gecko/20021120 Netscape/7.01 , Windows NT
This worksforme in a current build... probably one of David's incremental reflow
fixes to blocks fixed it.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.