If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla saves pixel thin window state upon startup; browser useless; new winows just as small

RESOLVED DUPLICATE of bug 167663

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 167663
15 years ago
13 years ago

People

(Reporter: Stephen Schaubach, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021007 Chimera/0.5+
Build Identifier: Mozilla 1.2beta  MacOS X

Mozilla 1.2 beta has, upon un-minimize left me with about a 2 pixel thick, and
about fourty pixel long window. I am unable to use the controls that would
normally appear in the window to maximize the window. 

Reproducible: Always

Steps to Reproduce:
1. manually copy the mozilla folder out of an older copy of mozilla to the
correct location. In my case I copied a 1.0.1 from another machine and placed it
in the Library folder of my laptop.
2. run the new 1.2beta and select the correct profile
3. it said it could not use the profile, so I hot cancel and it started up anyway
4. I changed the theme from classic to modern
5. I minimized it 
6. forced quit the application due to another error
7. start it back up and the pixel thin window should appear

8. I realize the steps are insane but the prefs (if corrupted) should be read in
and there should be an option to max the window from this state

Actual Results:  
start it back up and the pixel thin window should appear


Expected Results:  
given me either a message saying the prefs are bad and re-create them or just
figure out that the window in about 2 pixels wide and fix the size....minimally
you could have the window open up no smaller than 10x10 or something

I have had this happen in each version after 1.0 so I am setting the severity to
major

Comment 1

15 years ago
A workaround to get working windows again: delete the file localstore.rdf in
your profile directory.

*** This bug has been marked as a duplicate of 167663 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.