Closed Bug 1772192 Opened 6 months ago Closed 6 months ago

Main menu items have black text on dark-blue background when hovered

Categories

(Thunderbird :: Theme, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr91 unaffected, thunderbird102? fixed, thunderbird103 affected)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird102 ? fixed
thunderbird103 --- affected

People

(Reporter: thomas8, Assigned: Paenglab)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Main menu items have black text on dark-blue background when hovered, which makes for poor contrast. I guess we'll want the generic shade of grey as in app menu.

Not yet seen in 101.0b4 (64-bit), so this must have regressed pretty recently.

Flags: needinfo?(richard.marti)

Seen on 103.0a1 (2022-06-01) (64-bit), Win10

We use the system colours for the main menu elements. Unfortunately on W10 they aren't correctly/appropriately picked. I checked different applications and the highlight colour isn't consistent. Because of this I go back to the grey highlight background like FX does. This will affect W11 too as there is no special media query for W11.

Flags: needinfo?(richard.marti)
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Target Milestone: --- → 103 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/3c7ce2a7cba3
Don't use the -moz-MenuHover colors on Windows 10+. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED

Comment on attachment 9279396 [details]
Bug 1772192 - Don't use the -moz-MenuHover colors on Windows 10+. r=aleca

[Approval Request Comment]
User impact if declined: on Window 10 hard readable active main menuitems
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9279396 - Flags: approval-comm-beta?
Blocks: tb102found

Comment on attachment 9279396 [details]
Bug 1772192 - Don't use the -moz-MenuHover colors on Windows 10+. r=aleca

[Triage Comment]
Approved for beta

Attachment #9279396 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.