Dots in lists display as • on the Hollywood.com pages

VERIFIED WONTFIX

Status

()

Core
Internationalization
VERIFIED WONTFIX
16 years ago
16 years ago

People

(Reporter: Eric Erickson, Assigned: mkaply)

Tracking

({intl, pp})

Trunk
x86
OS/2
intl, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2b) Gecko/20021017
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2b) Gecko/20021017

In the page
http://http://www.hollywood.com/showtimes/theatre_detail.asp?searchtheatre=3226&searchzip=77094&searchradius=15
leader dots are displayed as • on my OS/2 System. This problem does not occur
with IE or the Windows Version of Mozilla 1.2b. This system is using SDD 7.11 at
a resolution of 1600x1200 at 64K colors.

Reproducible: Always

Steps to Reproduce:
1. Display Page at
http://http://www.hollywood.com/showtimes/theatre_detail.asp?searchtheatre=3226&searchzip=77094&searchradius=15
2. View page
3.

Actual Results:  
Page displayed with leader dots incorrectly.

Expected Results:  
Shown dots instead of the • character.
(Reporter)

Comment 1

16 years ago
Just tested under Netscape 4.61 on OS/2 and page is displayed correctly.
Where exactly are these leader dots?  I see that character in two places on the
page -- the left-hand links and between the show times in the middle.  In both
places the page explicitly asks for that character's unicode codepoint in the
HTML....
(Reporter)

Comment 3

16 years ago
The leader dots are part of the left hand lists and between the showtimes. Both
display as the wrong character.
Could you post a screenshot of what they display like for you?  For me they look
exactly like the list bullet in a <ul>...
(Reporter)

Comment 5

16 years ago
Created attachment 104599 [details]
Screen shot of Page with dots replaced by other character
thanks!

Sounds like an OS/2-only font issue....
Assignee: misc → yokoyama
Status: UNCONFIRMED → NEW
Component: Layout: Misc Code → Internationalization
Ever confirmed: true
Keywords: pp
OS: other → OS/2
QA Contact: nobody → ruixu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong
(Assignee)

Comment 7

16 years ago
Do you have Times New Roman MT 30 installed on your system?

What do you have set for your Unicode font?
(Reporter)

Comment 8

16 years ago
When I look in the Font Pallette I only see the Times New Roman font. Is there
any other way to check the fonts? And how do I check the unicode font?
(Assignee)

Comment 9

16 years ago
Open the font palette and double click on a font to display the font dialog.

Check in this font list for the Times New Roman MT 30 font.

Assignee: yokoyama → mkaply
(Reporter)

Comment 10

16 years ago
Nope, I have a Times New Roman, but no Times New Roman MT 30 listed.
(Assignee)

Comment 11

16 years ago
Because these characters are Unicode, you need a Unicode font to display them.

Go to preferences, select Font and select Unicode. Change these fonts to be
Arial. Arial has enough Unicode support to display these bullets correctly.

The core issue here is that on OS/2 we can't query a font as to whether or not
it has a glyph, so we have to assume that the font specified for the Unicode
font supports these glyphs.

Most people have Times New Roman MT 30 (which comes with Java), which is why we
default to that.

Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 12

16 years ago
Mark as verified per comment above.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.