Mozilla keeps asking me to open files I want to download

VERIFIED DUPLICATE of bug 86640

Status

SeaMonkey
Download & File Handling
--
minor
VERIFIED DUPLICATE of bug 86640
16 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.1) Gecko/20021024
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.1) Gecko/20021024

99.99% of the time, if I click on a link that goes to a downloadable file, I
want to save the file.  Mozilla always asks me if I want to do this - and, if a
helper application is known, it *ALWAYS* defaults to "open in [...]" rather than
"save to disk".  Nothing indicates what will happen if I uncheck "always ask
before opening this type of file", but it certainly looks as though it would
then *open* files - rather than saving them.

I want a "never in a million years try to use a helper application, always save
everything to disk" button.  I don't care that much how it works.  At a minimum,
if I select "save to disk", that should become the default for that type of
thing, until such time as I select the other option.  Ideally, there would be a
setting for "always save to disk, never use helper apps".


Reproducible: Always

Steps to Reproduce:
1. Click on zip file.
2. Select "save to disk..."
3. Repeat.

Actual Results:  
Mozilla kept offering to open zip files with winzip.

Expected Results:  
Save the files to disk without bugging me about stupid helper apps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Once the fact that this dialog is totally broken is fixed, selecting "save" and
unchecking that checkbox will do what you want.  In the meantime, you can set it
up by hand in the helper app preferences panel....

*** This bug has been marked as a duplicate of 86640 ***

Comment 2

16 years ago
verified dup. (Note that there's also bug 80557 / bug 88458)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.