Browser locked if timeout during toolbar customizing

VERIFIED DUPLICATE of bug 176183

Status

()

Firefox
Toolbars and Customization
VERIFIED DUPLICATE of bug 176183
15 years ago
11 years ago

People

(Reporter: Hans, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021028 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021028 Phoenix/0.4

When connecting to a page that timesout while you are in drag mode when
customizing toolbar. The timeout alert pops up locks the browser compleatly.

Reproducible: Always

Steps to Reproduce:
1.Surf to a site that timesout
2.Right click on toolbar to open "Cuztomize..." while it's trying to connect and
grab an icon, don't let go of it.
3.Wait for the timeout alert


Actual Results:  
Total lockdown of browser, can not interact with browser in any way.

Expected Results:  
Been able to click "Ok" on timeout alert popup.

Comment 1

15 years ago
*** Bug 177256 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Confirmed for Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b)
Gecko/20021028 Phoenix/0.4, although I wasn't able to reproduce it
every single time.  I can also see this problem if the alert box is
generated via JavaScript using the following page:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <body onload="window.setTimeout( 'alert( \'Hello!\' );', 10000 );">
    Alert box will appear in 10 seconds...
  </body>
</html>

It seems to depend on factors such as where the drag is at the time
the dialogue appears.  When I could see the fault I *was* able to
dismiss the dialogue and the toolbar configuration dialogue, but the
menubar entries remained greyed out and while over the menubar and
toolbar the pointer was still shaped like a hand.  Everything appeared
to be working normally over the content area and in the text entry
fields on the toolbar.

Comment 3

15 years ago
Hans, please query for existing bugs before reporting new ones. Reporting
duplicate bugs wastes a lot of developer and QA time. Thanks. 

*** This bug has been marked as a duplicate of 176183 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Mass verifiying old duplicates.
Status: RESOLVED → VERIFIED

Comment 5

15 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.