Closed Bug 177294 Opened 22 years ago Closed 19 years ago

Add "Age in days" filter to IMAP

Categories

(MailNews Core :: Filters, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jpd, Assigned: Bienvenu)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021028
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021028

When filtering messages, add relative dates as an option instead of explicit
dates, for example "date is x days ago" where x is a changeable number.

Currently, if you want to set a filter to move or delete messages that are (for
instance) over a month old, you need to edit your filter every day. When using
IMAP with a server that has a quota, having just such a filter is a very useful
tool.

Reproducible: Always

Steps to Reproduce:
WFM - "age in days" "is/is greater than/is less than"
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → WORKSFORME
No no no! That's not what I meant!

Can you set a filter that says "greater than 30 days ago?" I don't think you
can. You can set a filter that says "less than Jan 5, 2002", but in a few days
that will not be useful anymore (in fact, it won't be useful after it is run the
first time). 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
And there is no "age in days" in the version of Mozilla I'm using (Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030204) so if you
have that option, than this should be a bug fix rather than a feature request. 
"Age in Days" should be the 10th option in the list, just below "To or cc".

However, I just tested with a fake IMAP account, and the option doesn't exist
there. *grumbles* Been running into the differences with this protocol all day
now. Confirming and modifying summary. 
Although I figure there's a reason this isn't in yet that has to do with the
protocol. Compare bug 67421.

"Attachment status" and "label" are also missing in IMAP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: RFE: Add relative dates to mail filters → Add "Age in days" filter to IMAP
mass re-assign.
Assignee: naving → sspitzer
*** Bug 206883 has been marked as a duplicate of this bug. ***
*** Bug 237829 has been marked as a duplicate of this bug. ***
"Age in Days" is available as a filter of the Inbox (on the "Search Bar"),
could it be available in the "Tools > Message Filters..." menu?

Is the protocol the problem to implement this feature? 
From what I understand, IMAP downloads the message headers (including the date)
immediately, so filtering on date should not be an issue.  Bug 67421 is a red
herring -- it applies to filtering on the body text, and since IMAP postpones
downloading the body until you read the message it can't filter on the body
unless you force the download earlier, effectively eliminating one of the main
advantages of IMAP over POP. 

The "View" item on the search bar demonstrates that this type of filter is
possible, and it's absence is most likely an oversight. Also the fact that the
filters already exist for other date comparisons (less than [date], greater than
[date] etc) shows that all the info that is needed is already collected from the
IMAP server - the comparison only needs to be done to the current local date
minus x days/hours/months.
May I jump on this bug with another filter option that exists in POP3 but is
missing in IMAP?

When filtering on custom headers in POP3, the available options are "contains",
"doesn't contain", "is", "isn't", "begins with", and "ends with".

IMAP has only "contains", "is", "begins with", and "ends with", but lacks
"doesn't contain" and "isn't". I cannot find a reson why these should have been
intentionally excluded.
(In reply to comment #10)
> May I jump on this bug with another filter option that exists in POP3 but is
> missing in IMAP?

Actually, jumping in like that is discouraged, particularly when the problem has 
already been entered elsewhere.  See bug 242550.
> Actually, jumping in like that is discouraged

Ok, ignore my comment then. I thought it would be handy to have a general "IMAP
filters are inconsistent with POP3 filters" bug where all these things can be
found in one place.
*** Bug 233867 has been marked as a duplicate of this bug. ***
Almost 2 years old already. 

Is this really such a huge programming feat to include? IMAP server message age
may not be absolutely correct, but most "1970" emails are spam anyhow. 
*** Bug 255109 has been marked as a duplicate of this bug. ***
This patch works for me. BTW: What's the meaning of ->SetValidButNotShown(...)
?
*** Bug 233674 has been marked as a duplicate of this bug. ***
taking to review.
Assignee: sspitzer → bienvenu
Attachment #161198 - Flags: superreview+
Product: MailNews → Core
*** Bug 270906 has been marked as a duplicate of this bug. ***
Does this need to be checked in?
I checked this in a while ago, I believe.
Status: NEW → RESOLVED
Closed: 22 years ago20 years ago
Resolution: --- → FIXED
TB 1.0 doesn't have the age in days filter. I didn't find it with text search in
the the TB builds forum either. Is it included in a build yet? 
it's in trunk builds, not 1.0 builds. So it will be in 1.1 when that comes out,
or you can use a trunk nightly build if you're desperate for this feature and
willing to use a potentially unstable build :-)
(In reply to comment #23)
> it's in trunk builds, not 1.0 builds. So it will be in 1.1 when that comes out,
> or you can use a trunk nightly build if you're desperate for this feature and
> willing to use a potentially unstable build :-)

I have tried the latest nightly trunk build and it's not there. Also LXR shows
the relevant code is still unchanged:
http://lxr.mozilla.org/seamonkey/source/mailnews/base/search/src/nsMsgImapSearch.cpp#498
Maybe it was only enabled for search rather than filter?
Anyway, I checked it in, so we'll see in the next round of nightlies ;-)
so sorry, missed the imap part of this. I'll drive the fix in.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Bug 296502 has been marked as a duplicate of this bug. ***
(In reply to comment #26)
> so sorry, missed the imap part of this. I'll drive the fix in.

David, this seems to be in place for TB 1.0+0603 -- should this bug be marked 
Fixed or is there something else pending?
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=217034#c11 for a
possible workaround to this problem.

--j
yes, looks like it's fixed *on the trunk*, not in 1.05 or 1.06, or 1.0x
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: