Closed Bug 1773109 Opened 4 months ago Closed 3 months ago

Make native color layers active for YouTube fullscreen video

Categories

(Core :: Graphics, enhancement)

Unspecified
macOS
enhancement

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: bradwerth, Assigned: bradwerth)

References

Details

Attachments

(1 file)

The motivation for native color layers on macOS is to ensure that video players have the correct Core Animation Layer structure to qualify for macOS "detached" mode -- a low-power video mode. The YouTube fullscreen player page structure prevents native color layers from being used because the black backdrop it provides covers only the visible area and not all of the scrollable area of the page. Attempts to make the native color layer activate in this case led to regressions like Bug 1772867 and Bug 1773064 via the changes in D147566, which had to be rolled back.

This bug is tracking the effort to make YouTube activate native color layers as intended.

Bug 1772713 is another such regression. All of these issues were fixed by the landing of Bug 1772867 which largely reverted D147566.

Previously, a tile cache backdrop was an opaque color that was guaranteed
to cover the entire tile cache rect. This change makes it so that the
backdrop must only cover the visible area. For compositors that support
native color layers, this allows native color layers to be used more
often.

To make this work, the tile cache background color is updated whenever a
spanning backdrop is found. This ensures that tiles still clear to a
spanning color. The tile cache background is reset on each new scene, so
it won't carry a "stale" backdrop color.

Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/859b4b866b60
Change tile cache backdrops to only guarantee visible coverage. r=gw

Backed out changeset 859b4b866b60 (Bug 1773109) for causing remote failures.
Backout link
Push with failures <--> remote
Failure Log

Flags: needinfo?(bwerth)

On Windows, this is triggering Bug 1776474, which will have to be fixed first.

Depends on: 1776474
Flags: needinfo?(bwerth)
Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/20df8ec3b239
Change tile cache backdrops to only guarantee visible coverage. r=gw
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Regressions: 1778187
You need to log in before you can comment on or make changes to this bug.