Forwarded messages with attachments are not displayed w/standard "forwarding" information...

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: ali, Assigned: mscott)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

When a msg with an attachment is forwarded, the recipient of said message will
*not* see the original e-mail well-seperated from the (forwarding) sender's
comments.  (Behavior reproduced in Mozilla v1.1 for Win32)

Typically (when using "forward messages as attachment" mode), forwarded messages
will be displayed with the forwarder's comments, then a seperator, followed by
header info w/the original Subject, From, Date and To lines.  However, if the
forwarded message contains an attachment the recipient of the forwarded message
does *not* see this information!

When a forwarded msg w/attachment is received, the forwarder's comments will
*immediately* precede the original mail's text, w/o any seperator or other
indication (in the mail body) that the msg was forwarded.  Thus, the recipient
is not able to distinguish the contents of the original message from the
forwarder's comments.


Reproducible: Always

Steps to Reproduce:
1.Create a new mail message with a line of text, and add a small binary
attachment (~44kb, for example)
2.Send this msg to yourself.
3.When msg is received, *forward* it to yourself - add some comment text (e.g.,
"Forwarding this message")
4.When the forwarded msg is received, you'll see that your comments will be
*immediately* precede the original mail's text, w/o any seperator or other
indication (in the mail body) that the msg was forwarded.

Actual Results:  
Problem was reproduced.

Expected Results:  

The display of the forwarded msg w/attachment is different than that of a
forwarded msg *without* attachments; in the latter case, the receipient of the
forwarded msg sees the original e-mail text seperated from the (forwarding)
sender's comments, along with header details about the original message.
(Reporter)

Comment 1

16 years ago
Some more information on this - it looks like the buggy behavior described only
occurs when the attachment(s) size exceeds a certain threshold.

For instance, attaching a 17kb file does not cause the behavior ... but a 30kb
(or larger) *does*!  I don't know what the exact size threshold is, but any file
larger than 30kb should allow the problem to be recreated.

Updated

16 years ago
QA Contact: trix → yulian
QA Contact: yulian → stephend

Comment 2

16 years ago
This bug occurs in the latest 1.3 alpha as well, Windows 2000 OS.  It's a
show-stopper for forwarding any sort of large attachment.  The recipient gets a
message full of mime characters that are not encoded properly.

Happens on ALL systems tested!  It also occurs in Netscape 7.

Comment 3

15 years ago
I am not seeing this bug in 1.5 Final.  I assume reporter is using Forward As 
Attachment, as an Inline forward would never exhibit this problem.

Ali Shamsi, is this bug still a problem for you?  Have you upgraded to a newer 
version of Mozilla?

Comment 4

15 years ago
No response from reporter; =>WFM

Ali Samshi, if this bug is still a problem for you, feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.