onFocus of document does open pop-up even if we have pop-ups blocked.

VERIFIED DUPLICATE of bug 159036

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 159036
16 years ago
13 years ago

People

(Reporter: Prashant Desale, Assigned: dveditz)

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
if we open window onfocus of document object then it does open window. (even with
open unrequested windows unchecked")
Sure it involves user action to click anywhere in document (even inside inputs)
but this could be the easiest workaround since user is bound to click on
document for something (mostly to fillout any information asked or to provide
userID's & passwords or just to scroll or anything like that).

STEPS TO REPRODUCE:
1) Uncheck preference 'Open unrequested windows'.
2) Load testcase I'm going to attach.
3) click anywhere in your content window (document).

EXPECTED RESULTS:
No Popup window should showup.

ACTUAL RESULTS:
Pop-up showsup loading yahoo.com
If you try to close pop-up, it keeps on popping again (because parent document
gets focus back again).

This could be easy workaround. 

Testcase following.
(Reporter)

Comment 1

16 years ago
Created attachment 104573 [details]
Testcase
over to dveditz.
Assignee: ben → dveditz
Keywords: qawanted
QA Contact: sairuh → nobody
(Assignee)

Comment 3

16 years ago
as currently designed, onfocus != onload, onunload or setTimeout

*** This bug has been marked as a duplicate of 159036 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
verified dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.