Closed Bug 1774096 Opened 2 months ago Closed 2 months ago

Mailing list items in contacts list show up empty in view pane and are not editable (nor exportable)

Categories

(Thunderbird :: Address Book, defect, P2)

Thunderbird 102

Tracking

(thunderbird_esr102 fixed, thunderbird102 affected)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird_esr102 --- fixed
thunderbird102 --- affected

People

(Reporter: thomas8, Assigned: darktrojan)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, useless-UI, ux-error-prevention)

Attachments

(3 files)

103.0a1 (2022-06-13) (64-bit), Win10
102.0b4 (64-bit)

As things stand (and we haven't changed that for 102), mailing lists are conceptually (and technically) contained in their parent address book, and consequently, they are displayed side by side with contacts. This makes sense:

  • matches the containing AB concept
  • ux-consistent with similar trees (e.g. subfolders in file manager)
  • simplifies and enables searching for mailing lists (!).

Unfortunately, the mailing list items in the list have become pretty much no-op, which is a confusing, error-prone, and counter-intuitive regression over TB 91.

STR

  1. Have a mailing list List1 with several members in an address book, e.g. Personal Address Book.
  2. Select All Address Books (factory default view iirc), or Personal Address Book.
  3. In the list of contacts (not in directory pane), select the mailing list.
  4. Try to perform the following actions on the selected list:
  • View list contents/members
  • Edit list
  • Export list

Actual result:

  • Selected mailing list shows up empty in the view pane (which is completely blank). Iow, viewing the list from here is not possible. This is quite error-prone as users may get confused and delete the list, wrongly believing that it is empty (so this becomes a case of ux-error-prevention).
  • Cannot Edit the list from here - what!? (Double-click does nothing, Enter does nothing, no Edit action on context menu, and nothing on main menu either). But editing aka list management is one of the main actions for lists in the AB.
  • Export is also missing (compared to the mailing context menu in the directory tree - why are context menus even different?)

Expected result:

  • Selected mailing list should show something in the view pane
    • list name, [description], and list of members
    • ideally with a list toolbar for more actions, esp. Write (with dropdown flavors: To, CC, Bcc), and Edit
  • Selected mailing list should be editable
    • Edit button in view pane
    • Restore Edit action in context menu
    • Restore Edit as default action (Double-click or Enter on selected list to edit)
  • Mailing list context menu should be the same between directory list and contacts list
    • For consistency, add Export action also to the context menu of a mailing list in contacts list

Fwiw, the workaround of going through the directory tree to view or edit mailing lists won't cure the problem in the contacts list, won't work for All Address Books, and defeats the convenience and efficiency of being able to search for a mailing list and view or edit it directly from the list of found items.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9281116 - Attachment description: WIP: Bug 1774096 - Fill the Address Book display pane when multiple contacts or lists are selected. → Bug 1774096 - Fill the Address Book display pane when multiple contacts or lists are selected. r=aleca

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/5732d9540ec7
Fill the Address Book display pane when multiple contacts or lists are selected. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

Ick, my test doesn't really work on Mac for some reason.

Comment on attachment 9281116 [details]
Bug 1774096 - Fill the Address Book display pane when multiple contacts or lists are selected. r=aleca

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):

Attachment #9281116 - Flags: approval-comm-beta?

Comment on attachment 9281116 [details]
Bug 1774096 - Fill the Address Book display pane when multiple contacts or lists are selected. r=aleca

[Triage Comment]
It's a lot of change. I'm inclined to suggest this wait to a 102 point release after it bakes on beta.
I suspect the use cases are infrequent enough that it won't hurt to wait.

Attachment #9281116 - Flags: approval-comm-beta? → approval-comm-beta-

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fd29a6f3c249
follow-up - Fix test on Mac. r=mkmelin

Comment on attachment 9281116 [details]
Bug 1774096 - Fill the Address Book display pane when multiple contacts or lists are selected. r=aleca

[Triage Comment]
This wound up being a requirement for bug 1751978 and 1774514 (and possibly others)

Attachment #9281116 - Flags: approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.