Closed Bug 1774117 Opened 19 days ago Closed 17 days ago

Calendar view reloads when switching tabs

Categories

(Calendar :: Calendar Frontend, defect)

defect

Tracking

(thunderbird102 fixed)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird102 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

In switchToView we deactivate the current view and then activate the new view, but we shouldn't do this if they're the same view. It forces the view to reload.

Short-circuits switchToView, if the new view is the same as the old view, so that we don't call .isActive = false and .clearItems() on it.

Assignee: nobody → geoff
Status: NEW → ASSIGNED

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/10534776b797
Only deactivate the current calendar view if it's being hidden. r=#thunderbird-reviewers,mkmelin

Status: ASSIGNED → RESOLVED
Closed: 17 days ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

Comment on attachment 9281331 [details]
Bug 1774117 - Only deactivate the current calendar view if it's being hidden. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: calendar view reloads itself every time you switch tab to it
Testing completed (on c-c, etc.): landed yesterday
Risk to taking this patch (and alternatives if risky):

Attachment #9281331 - Flags: approval-comm-beta?

Comment on attachment 9281331 [details]
Bug 1774117 - Only deactivate the current calendar view if it's being hidden. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9281331 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.