hotmail.com - javascript:document.goto returns Error: missing name after . operator

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P1
normal
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: brent, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows 98; en-US; rv:1.0.1)  Gecko/20020823 Netscape/7.0
Build Identifier: Mozilla 1.2 beta

In hotmail's junk mail folder, you can click on a message's checkbox and if you
want to mark it as legit, there is a button that you can click on to start this
process.  If you do this, you will go be presented with some new pages where you
go thru a procedure, the final step of which is to click on a button labeled
"Return to Junk Mail Folder" or something like that.  Clicking on that button in
IE works: you are brought back to the junk mail folder.  But when you click on
this button in Moz, it does nothing at all.

Reproducible: Always

Steps to Reproduce:
1. get a hotmail account
2. go thru the steps outlined in the details section
3.

Actual Results:  
Nothing happens in Mozilla

Expected Results:  
Brought me back to the junk mail folder

This has been a very long standing issue with Mozilla and hotmail; not sure if
it is a bug in Mozilla or hotmail (more likely).
do you get a error in teh JS Console ?
(Reporter)

Comment 2

15 years ago
Matti (marquee sucks)  writes:

>do you get a error in teh JS Console ?

I am not sure!

I have, in fact, thought about this checked for it in the past and seen an error
in the JS Console right after hitting the return to junk mail folder button. 
The problem is that I forgot to check and clear the JS Console for errors right
before starting the process, so I cannot conclusively say whether or not the
error message applies to clicking on the return to junk mail folder button. 
Furthermore, I recall that I the last time that I checked the JS Console button
after doing this process, that I did not see any error messages at all.  So, i
am not sure at this point what it is.  (Part of the problem from a debugging
viewpoint is that hotmail recently hired someone intelligent, Brightmail?, to do
spam filtering for them, and I am now getting much fewer legit messages stuck in
my junk mail folder.  This, for the first time in a couple years, is making
hotmail usable.  But it also gives me fewer opportunities to test this.)
(Reporter)

Comment 3

15 years ago
First, to more precisely expand on my original description, note that after you
click on the button to mark a junk message as legit, you will first be presented
with a page that has 2 radio button choices; you can chose either one, and then
click on the Next button on the bottom; you will be taken to a second page at
this point -- Moz seems to working fine with hotmail up to now.  On this second
page, however, if you try clicking on the "Return To Junk Mail Folder" button,
nothing will happen.

I just did the above process, taking care to clear the Javascript Console of all
messsages first, and was able to confirm that the reason why nothing happens
when you click on the "Return To Junk Mail Folder" button is because of the
following Javascript error:

	Error: missing name after . operator
	Source Code:
	document.goto.curmbox.value='F000000005';goto.submit()

I am including the complete source code for this page below, but the relevant
section (the "goto" form) seems to be:

	<form name="goto" action="/cgi-bin/HoTMaiL">
	<hr size="1" color="#8CA5B5">
	<input type="hidden" name="curmbox" value="F000000005">
	<input type="hidden" name="from" value="HoTMaiL">
	<input class="Bsbttn" type="submit" value="Return To Junk Mail Folder"
onClick="document.goto.curmbox.value='F000000005';goto.submit()"> &nbsp;
	<input class="Bsbttn" type="submit" value="Go To Inbox"
onClick="document.goto.curmbox.value='F000000001';goto.submit()">
	</form>

I hope that this will help those of you with more knowledge of JS than me to see
what the problem might be.


<html>
<head>
<title>MSN Hotmail - This Is Not Junk Mail</title>
<link rel="stylesheet" href="/cgi-bin/dasp/EN/hotmail___906000056.css">
<script language="JavaScript"
src="/cgi-bin/dasp/EN/hotmail___906050002.js"></script>
</head>
<body style="background-color:#336699;" >
<a name="top"></a>
<table border=0 cellpadding=0 cellspacing=0 bgcolor=#336699>
<tr valign=top>
<td width="100%" style="padding-top:3px;">
<table border=0 cellpadding=0 cellspacing=0>
<tr>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/420??PS=" class="tab"><b>MSN Home</b></a>

&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/421??PS=" class="tab"><b>My MSN</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td>&#160;&#160;&#160;<font
class='tab'><b>Hotmail</b></font>&#160;&#160;&#160;</td><td><font
class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/423??PS=" class="tab"><b>Search</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/424??PS=" class="tab"><b>Shopping</b></a>

&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/425??PS=" class="tab"><b>Money</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/426??PS=" class="tab"><b>People &amp;
Chat</b></a>
&#160;&#160;&#160;</td><td />
</tr></table>
<table cellpadding=1 cellspacing=0 width="100%" border="0">
<tr valign="middle">
<td>

<a href="http://g.msn.com/1HM7EN/141??PS="><img
src="http://64.4.22.24/lgo_msn_118x40.gif" width=118 height=40 border=0 alt="go
to MSN"></a>
</td><td valign="bottom" width="100%">
</td>
</tr></table>
</td>
<td rowspan="2" style="padding-left:4px" valign="top" width="160">
<a
href="http://lw15fd.law15.hotmail.msn.com/cgi-bin/logout?curmbox=F000000005&a=e7c2dd783531ee4df52e9be25845a337&t=1036125607&loru=&id=2&fs=1&cb=_lang%3dEN%26country%3dUS&ct=1036125607"><img
src="http://64.4.22.24/dosoEN.gif" CLASS="PassportSignOut" alt="Sign out of .NET
Passport sites" border=0></a><p>
<table border="0" cellspacing="0" cellpadding="0" width="156">
<tr><td><font class="sb" color=#FFCC66><label for="q">Search the
Web</label></font></td></tr>
<form method="GET" name="websearch" action="http://search.msn.com/results.asp"
style="margin-bottom:0px;margin-bottom:0px;">
<input type="Hidden" name="RS" value="CHECKED">
<input type="Hidden" name="Form" value="HM">
<input type="Hidden" name="cp" value="1252">
<input type="Hidden" name="v" value=1>
<tr>
<td height=25 valign=top>

<div style="position:absolute">
<input type="text" id="q" name="q" size=20 accesskey="S"
style="width:120px;"><input type="image" vspace=0 hspace=0
src="http://64.4.22.24/searchgo.gif" border=0 alt="Begin your Web search"
style="position:absolute;left:90;top:-2">
</div>
</td>
</tr>
</form>
</table>
</td>
</tr>
<tr style="padding-top:6px">
<td>
<table border="0" cellpadding="0" cellspacing="0" width="100%">
<tr>
<td width=129 valign=top><img src="http://64.4.22.24/lgo_0hm_129x36.off.gif"
align="top"></td>
<td nowrap background="http://64.4.22.24/menu0.off.bg.gif"><a
href="/cgi-bin/hmhome?curmbox=F000000005&a=e7c2dd783531ee4df52e9be25845a337"
class="menu" tabindex="120"><font class="menu">Home</font></a>&nbsp;</td>
<td><img src="http://64.4.22.24/menu0.off.off.separator.gif"></td>

<td nowrap background="http://64.4.22.24/menu0.off.bg.gif"><a
href="/cgi-bin/HoTMaiL?curmbox=F000000001&a=e7c2dd783531ee4df52e9be25845a337"
class="menu" tabindex="121"><font class="menu">Inbox</font></a>&nbsp;</td>
<td><img src="http://64.4.22.24/menu0.off.off.separator.gif"></td>
<td nowrap background="http://64.4.22.24/menu0.off.bg.gif"><a
href="/cgi-bin/compose?curmbox=F000000005&a=e7c2dd783531ee4df52e9be25845a337"
class="menu" tabindex="122"><font class="menu">Compose</font></a>&nbsp;</td>
<td><img src="http://64.4.22.24/menu0.off.off.separator.gif"></td>
<td nowrap background="http://64.4.22.24/menu0.off.bg.gif"><a
href="/cgi-bin/addresses?curmbox=F000000005&a=e7c2dd783531ee4df52e9be25845a337"
class="menu" tabindex="123"><font class="menu">Contacts</font></a>&nbsp;</td>
<td><img src="http://64.4.22.24/menu0.off.end.gif"></td>
<td nowrap bgcolor="#336699" background="http://64.4.22.24/menu0.end.bg.gif"
align=center>&nbsp;&nbsp;&nbsp;&nbsp;<a
href="/cgi-bin/options?curmbox=F000000005&a=e7c2dd783531ee4df52e9be25845a337"
class="swb" color="#ffffff" tabindex="124"><font class="swb"
color="#ffffff">Options</font></a></td>
<td nowrap bgcolor="#336699" background="http://64.4.22.24/menu0.end.bg.gif"
align=center>&nbsp;&nbsp;&nbsp;&nbsp;<a
href="javascript:CallPaneHelp('HM_NotBulk','For related information, click a
topic:');" class="swb" color="#ffffff" tabindex="125"><font class="swb"
color="#ffffff">Help</font></a></td>
<td nowrap bgcolor="#336699" width="100%" align="right"
background="http://64.4.22.24/menu0.end.bg.gif">&nbsp;</td>
</tr>
</table>
</td></tr></table>

<table border="0" cellpadding="0" cellspacing="0"><tr>
<td bgcolor=#93BEE2><img src='http://64.4.22.24/spacer.gif' width="612"
height="1"></td>
<td width="160" bgcolor="#336699" valign="top" rowspan=2 bgcolor=red>
<iframe
src="http://rad.msn.com/ADSAdClient31.dll?GetAd?PG=PROHO3?NA=1140?SC=D1?PS=?PI=44364?UC=1?ID=000120A74C300099?NC=9523?AP=1090"
name="sidebar" id="sidebar" width="160" height="600" marginwidth="0"
marginheight="0" scrolling="no" frameborder="0" border="0"></iframe>
</td>
</tr><tr valign=top><td width="100%" valign=top bgcolor="#ffffff">
<!-- FILE: title.asp-->
<table border=0 cellpadding=0 cellspacing=0 width="100%">
<tr bgcolor=#93BEE2 align="center">
<td align="left" valign="middle">&nbsp;&nbsp;<font
class="sBL2b">brentboyer@hotmail.com</font></td>
<td width=100% align="right" valign="middle" style="padding-top:3px;">
&nbsp;
</td>
<td nowrap><font class="title">This Is Not Junk Mail</font>&nbsp;</td>
</tr>

<tr bgcolor=#93BEE2 align="center"><td colspan="3"><img
src="http://64.4.22.24/spacer.gif" width="1" height="5"></td></tr>
</table><p>
<table border=0 cellpadding=0 cellspacing=0 id="mainTable" width=610>
<tr>
<td width=15>&nbsp;</td>
<td>
<table cellpadding=5 border=0 width=580>
<tr>
<td> 
<font class="Wf">The address <b>Erpjob1@aol.com</b> has been added to your Safe
List.
<p>Messages from addresses on your Safe List are always delivered to your Inbox,
never to the Junk Mail Folder.
<p>To edit your Safe List go to the <a
href="/cgi-bin/block?curmbox=F000000005&a=e7c2dd783531ee4df52e9be25845a337&from=options&list=white&white=1">Safe
List</a> page.</font>

</td>
</tr>
</table>
<br>
<table width="580" cellpadding="0" cellspacing="0">
<tr>
<td align="right">
<form name="goto" action="/cgi-bin/HoTMaiL">
<hr size="1" color="#8CA5B5">
<input type="hidden" name="curmbox" value="F000000005">
<input type="hidden" name="from" value="HoTMaiL">
<input class="Bsbttn" type="submit" value="Return To Junk Mail Folder"
onClick="document.goto.curmbox.value='F000000005';goto.submit()"> &nbsp;
<input class="Bsbttn" type="submit" value="Go To Inbox"
onClick="document.goto.curmbox.value='F000000001';goto.submit()">
</form>
</td>
</tr>

</table>
</td>
</tr>
</table>
</td>
</tr></table>
<table border=0 cellpadding=0 cellspacing=0 width=100% bgcolor=#336699>
<tr>
<td height="5"><spacer type="block" height="5" width="5"></td>
</tr>
<tr valign=top>
<td height="20">
&nbsp;&nbsp;&nbsp;&nbsp;<a href="http://g.msn.com/1HM7EN/141??PS="
class="tagline">MSN - More Useful Everyday</a>			
</td>
</tr>
<tr height="22" valign="top">

<td>
<table border=0 cellpadding=0 cellspacing=0>
<tr>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/420??PS=" class="tab"><b>MSN Home</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/421??PS=" class="tab"><b>My MSN</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td>&#160;&#160;&#160;<font
class='tab'><b>Hotmail</b></font>&#160;&#160;&#160;</td><td><font
class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;

<a href="http://g.msn.com/1HM8ENXX/423??PS=" class="tab"><b>Search</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/424??PS=" class="tab"><b>Shopping</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/425??PS=" class="tab"><b>Money</b></a>
&#160;&#160;&#160;</td><td><font class='msnNav'>|</font></td>
<td nowrap>&#160;&#160;&#160;
<a href="http://g.msn.com/1HM8ENXX/426??PS=" class="tab"><b>People &amp;
Chat</b></a>

&#160;&#160;&#160;</td><td />
</tr></table>
</td>
</tr><tr>
<td>
<table border=0 cellspacing=0 cellpadding=0>
<tr>
<td bgcolor="d6e7ef" height="1"><spacer type="block" height="1" width="1"><td>
</tr><tr>
<td height="20" style="padding-left:10px" nowrap>
&nbsp;<font class="msnNav">&copy; 2002 Microsoft Corporation. All rights
reserved.</font> <a href="http://g.msn.com/1HM7EN/147??PS=" target="_top"
class="msnNav">TERMS OF USE</a>
&nbsp;&nbsp;<a href="http://g.msn.com/1HM7ENUS/164??PS=" target="_top"
class="msnNav">Advertise</a>

&nbsp;&nbsp;<a href="http://g.msn.com/1HM7EN/146??PS=" target="_top"
class="msnNav">TRUSTe Approved Privacy Statement</a>
&nbsp;&nbsp;<a href="http://g.msn.com/1HM7ENUS/163??PS=" target="_top"
class="msnNav">GetNetWise</a>
</td>
</tr>
</table>
</td>
</tr>
</table>
</body>
</html>
<!-- H: F48.law15.internal.hotmail.com -->
<!-- V: WIN2K 09.06.00.0058 i -->
<!-- D: Oct 24 2002 17:22:57-->

Comment 4

15 years ago
reporter (brent): can you reproduce this bug with a recent build of mozilla (for
example, 1.3a)? if so, please comment again with details. if not, please resolve
this bug as WORKSFORME. thanks.
(Reporter)

Comment 5

15 years ago
michael lefevre asks:
	reporter (brent): can you reproduce this bug with a recent build of mozilla (for
	example, 1.3a)? if so, please comment again with details.

Yes I can reproduce it with the latest production release, Mozilla 1.2.1.  (I
generally avoid alpha and even beta software if possible, but if you know that
1.3a has a fix for this type of issue, I would give it a spin.)


I finally had some junk email today that was actually legit (since hotmail
started using Brightmail to do spam filtering, false negatives have gone way
down...).

I followed the same procedure as described in my previous postings.  The 3
Javascript console error messages that I got this time after I clicked on the
"Return To Junk Mail Folder" button are:

	Error: missing name after . operator
	Source Code: document.goto.curmbox.value='F000000005';goto.submit()


	Error: element has no properties
	Source File: chrome://cookie/content/cookieNavigatorOverlay.xul
	Line: 128


	Error: element has no properties
	Source File: chrome://cookie/content/cookieNavigatorOverlay.xul
	Line: 128


One thing that I should mention: in order to handle a hotmail bug (see
	http://bugzilla.mozilla.org/show_bug.cgi?id=174651
) I manually overrode my user agent using
	user_pref("general.useragent.override", "Mozilla/5.0 (Windows; U; Windows 98;
en-US; rv:1.0.1)  Gecko/20020823 Netscape/7.0");
as described in the above bug report.  Not sure if that makes any difference or
not.  Since The Beast has apparently added Mozilla as a supported browser, I can
probably delete the above line from my prefs.js file and try again.

Comment 6

15 years ago
I can confirm that bug with version 1.2.1 & 1.2.1(de-at) using the original
installation files.

Comment 7

15 years ago
i got an issue like that. May the reporter post his comment as attachment or
else attach a screenshot?
Blocks: 114158

Comment 8

15 years ago
I can confirm this bug with a recent nightly (Mozilla/5.0 (Windows; U; Win98;
en-US; rv:1.4a) Gecko/20030302). Javascript console give the error reported in
comment #3 and 5: 

Error: missing name after . operator
Source Code:
document.goto.curmbox.value='F000000005';goto.submit()

Comment 9

15 years ago
just typing "javascript:alert(document.goto);" in location bar does the same thing

-> DOM0
Assignee: asa → dom_bugs
Component: Browser-General → DOM Level 0
QA Contact: asa → ashishbhatt
Summary: mozilla does not work with hotmail's junk mail folder → javascript:document.goto returns Error: missing name after . operator

Comment 10

15 years ago
-> tech evangelism

document.goto is invalid (since goto is a reserved word). should be
document.forms['goto']
Assignee: dom_bugs → english-us
Component: DOM Level 0 → English US
Product: Browser → Tech Evangelism
QA Contact: ashishbhatt → english-us
Version: Trunk → unspecified

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: evang500
Priority: -- → P1
Summary: javascript:document.goto returns Error: missing name after . operator → hotmail.com - javascript:document.goto returns Error: missing name after . operator

Comment 11

14 years ago
*** Bug 208569 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
I believe this bug has been fixed already. Was under tech evang.

Comment 13

14 years ago
I can confirm that that bug has been resolved with the re-design of HoTMaiL.
Should be RESOLVED.

Comment 14

14 years ago
yep. fixed. thanks folks.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.