Can't do Popup whitelisting from windows opened without status bars

VERIFIED WONTFIX

Status

()

Firefox
General
VERIFIED WONTFIX
16 years ago
15 years ago

People

(Reporter: James Chaldecott, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In Phoenix 0.4 you can't whitelist a site for popups from a (requested) popup
window, because the window doesn't have a status bar, so you can't see the "i"
icon. Perhaps you could make the status bar visible if a (requested) popup tried
to create another  ("unrequested") popup.

Steps to reproduce:
1) Enable popup blocking
2) Go to www.dabs.com
3) Click one of the "More Info" links (doesn't matter which) to open the
"Product Information" popup window for a product.
4) Click the "Reviews" 'tab' in that window.
5) Click the link "Read a customer review of this product"
6) This brings up a (requested) popup ("You are leaving dabs.com!") which itself
tries to open a new window which contains the actual review. The code is:

	<script language="javascript">
	<!--
	
window.open('http://www.dabs.com/referer.asp?http://www.consumer-reviews.co.uk/dabs/read.asp?code=16YG','newwindow');
		window.focus();
	//-->
	</script>

Phoenix displays the message about popup blocking and tells the user about the
"i" icon, but the "i" icon is not visible because the popup window doesn't have
a statusbar.

I can get round this easily enough by adding www.dabs.com to the whitelist in
the preferences, but it would be nice to have the icon for newbies ;-)

PS. Keep up the good work, the whitelist is a great addition. I've only had it
10mins and already I miss it when it's not there! :-)

Updated

16 years ago
Summary: Can't do Popup whitelisting from popups → Can't do Popup whitelisting from windows opened without status bars

Comment 1

16 years ago
I *do* get the "i" icon at the bottom of the browser window when I follow these
steps. To make sure we're talking about the same window I will attach a
screenshot of it.

Comment 2

16 years ago
Created attachment 104792 [details]
Screenshot of popup window with the "i" icon

Comment 3

16 years ago
I just realized that I have the option "Hide the status bar" unchecked under
"Applow scripts to:" in Preferences. Without that I guess this bug is valid.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

16 years ago
Yes, that is the same window I was talking about. 

FYI, I'd not spotted that preference. AFAIK, Phoenix defaults to it being
disabled , so this bug will show up if you enable pop-up blocking (does that
default to enabled?). I think I'll use it for now, but we should probably still
do something. 

Comment 5

16 years ago
The easies workaround would be to just dissalow sites to "Hide status bar" by
default. Blake?

Comment 6

16 years ago
we've added whitelisting additions in the preferences so this is not going to be
changes. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 7

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.