Closed Bug 1774899 Opened 2 years ago Closed 2 years ago

Update PDF.js to new version be2dfe45f96fa58a1926f764fd64d2416cecc501 from 2022-06-17 17:37:43

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
103 Branch
Tracking Status
firefox103 --- fixed

People

(Reporter: update-bot, Assigned: calixte)

References

(Blocks 1 open bug)

Details

(Whiteboard: [3pl-filed][task_id: GcJlzOjcReCjFeJrDm7-6Q])

Attachments

(1 file)

This update covers 6 commits:


7e3941da9d4647a706628cae02adb54966e80cc4 by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/7e3941da9d4647a706628cae02adb54966e80cc4
Authored: 2022-06-17 15:20:40 +0200
Committed: 2022-06-17 17:36:38 +0200

[JS] Hide field borders and buttons (#15053)

  • Since the border belongs to the section containing the HTML
    counterpart of an annotation, this section must be hidden when
    a JS action requires it;
  • it wasn't possible to hide a button in using JS.

Files Added:

  • test/pdfs/issue15053.pdf
  • test/pdfs/issue15053.pdf

Files Added:

  • src/display/annotation_layer.js
  • test/integration/scripting_spec.js
  • test/pdfs/.gitignore
  • src/display/annotation_layer.js
  • test/integration/scripting_spec.js
  • test/pdfs/.gitignore

bd5e1a9540735bd9c78a6c2c4126e7d66200121e by Maxim Mazurok

https://github.com/mozilla/pdf.js-/commit/bd5e1a9540735bd9c78a6c2c4126e7d66200121e
Authored: 2022-06-17 11:33:07 +1000
Committed: 2022-06-17 11:33:07 +1000

Fix "Good Beginner Bugs" link

Seems like the label was changed and the link needs to be updated

Files Added:

  • README.md
  • README.md

e7dc1ef4f3f691ce1343c9c5d4e6ecd15cae6a37 by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/e7dc1ef4f3f691ce1343c9c5d4e6ecd15cae6a37
Authored: 2022-06-16 18:16:49 +0200
Committed: 2022-06-16 19:53:07 +0200

[Editor] - Add the ability to directly draw after selecting ink tool

  • Right now, we must select the tool, then click to select a page and
    click to start drawing and it's a bit painful;
  • so just create a new ink editor when we're hovering a page without one.

Files Added:

  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/display/editor/ink.js
  • src/display/editor/tools.js
  • web/annotation_editor_layer_builder.css
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/display/editor/ink.js
  • src/display/editor/tools.js
  • web/annotation_editor_layer_builder.css

64cce1269e3a1ac6c39a49d43bbd97f863cfb0c4 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/64cce1269e3a1ac6c39a49d43bbd97f863cfb0c4
Authored: 2022-06-15 10:29:24 +0200
Committed: 2022-06-15 10:37:20 +0200

Add basic support for non-embedded ArialUnicodeMS fonts (issue 15044)

This appears to be a Microsoft-specific version of the regular Arial font, hence we simply map this to Helvetica in the same way that we treat many other Arial-named fonts.

Files Added:

  • test/pdfs/issue15044.pdf.link
  • test/pdfs/issue15044.pdf.link

Files Added:

  • src/core/standard_fonts.js
  • test/test_manifest.json
  • src/core/standard_fonts.js
  • test/test_manifest.json

4902ad89239c342aa7f649afd8e1bd305e4f6477 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/4902ad89239c342aa7f649afd8e1bd305e4f6477
Authored: 2022-06-12 23:15:56 +0200
Committed: 2022-06-13 10:47:37 +0200

Use modern DOM methods a bit more (PR 15031 follow-up)

Apparently the ESLint rule added in PR 15031 wasn't able to catch all cases that can be converted, which is probably not all that surprising given how some of these call-sites look.

Files Added:

  • external/webL10n/l10n.js
  • src/display/annotation_layer.js
  • web/base_tree_viewer.js
  • web/overlay_manager.js
  • web/text_highlighter.js
  • external/webL10n/l10n.js
  • src/display/annotation_layer.js
  • web/base_tree_viewer.js
  • web/overlay_manager.js
  • web/text_highlighter.js

2dca14028d7f1a8be0b998d15b157bc9e43b69db by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/2dca14028d7f1a8be0b998d15b157bc9e43b69db
Authored: 2022-06-13 09:48:40 +0200
Committed: 2022-06-13 10:08:39 +0200

Extend getGlyphMapForStandardFonts with some Hebrew entries (issue 15033)

This only adds the minimum entries required in order to render the referenced document correctly, rather than trying to support "all" Hebrew glyphs, to ensure that all lines in getGlyphMapForStandardFonts are covered by tests.

Files Added:

  • test/pdfs/issue15033.pdf.link
  • test/pdfs/issue15033.pdf.link

Files Added:

  • src/core/standard_fonts.js
  • test/test_manifest.json
  • src/core/standard_fonts.js
  • test/test_manifest.json

Assignee: nobody → cdenizet
Status: NEW → ASSIGNED
Pushed by cdenizet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce6c834568c2
Update PDF.js to be2dfe45f96fa58a1926f764fd64d2416cecc501 r=pdfjs-reviewers,calixte
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

This bug is being closed because a newer revision of the library is available.
This bug will be marked as a duplicate of it (because although this bug is older, it is superseded by the newer one).

Resolution: FIXED → DUPLICATE

Tom, can you please look into https://bugzilla.mozilla.org/show_bug.cgi?id=1774899#c5 since it seems like a problem if the Update Bot changes a previously RESOLVED FIXED bug to a duplicate like that?

Flags: needinfo?(tom)
Resolution: DUPLICATE → FIXED
No longer regressions: 1779742
Regressions: 1778692
You need to log in before you can comment on or make changes to this bug.