Closed Bug 177494 Opened 21 years ago Closed 20 years ago

[ps] problem while printing to ps file

Categories

(Core :: Printing: Output, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: dbrouard, Assigned: zhayupeng)

References

()

Details

Attachments

(4 files)

Hi, I'm using Mozilla 1.0 on a Debian GNU/Linux 3.0 ( aka Woody )

While writing a web page using css2, I had a problem. If I a web object use this
property:   "border:1px solid black", the visualization is ok ( see foo.html ),
the preview is also ok, but when I print to a ps file, the borders of the whole
page are marked with a black line ( see mozilla.ps ).

It doesn't appear if the css property is "border: 1px dashed black"

The problem I detect may be viewed at ( foo.html and the ps file, mozilla.ps ):

            www.conysis.com/~diego/test-mozilla
Confirming bug per sample output...
Status: UNCONFIRMED → NEW
Ever confirmed: true
The output of the Xprint module looks OK for me, I guess this issue is
Postscript module specific...
Summary: problem while printing to ps file → [ps] problem while printing to ps file
You said:

        The output of the Xprint module looks OK for me, I guess this issue is
        Postscript module specific...

¿Did you mean a Postscript module of Mozilla or of the system?

If the problem is the Postscript module of Mozilla, ¿how did you generate the
correct ps file?

You also said:

        Testcase printed with 2002-10-28-08-trunk Xprint module (300 DPI, DIN-A4)

¿How can you change the module? ¿Adding a printer to the system?
Diego Brouard wrote:
> > The output of the Xprint module looks OK for me, I guess this issue is
> > Postscript module specific...
> 
> Did you mean a Postscript module of Mozilla or of the system?

It means:
Mozilla comes with two print modules:
1. Postscript module (the old&&buggy one, default if there is no Xprint
module)
2. Xprint module

> If the problem is the Postscript module of Mozilla, 
> how did you generate the correct ps file?

I have Xprint installed on my box. If it's installed you can use it - and then
you'll get the correct output, too... :)

> > Testcase printed with 2002-10-28-08-trunk Xprint module (300 DPI, DIN-A4)
> 
> How can you change the module? ¿Adding a printer to the system?

You have to install the Xprint server side - "Xprt". See
http://mozilla.org/releases/mozilla1.0/#printing ; and Debian has a "Xprint"
package, see http://packages.debian.org/unstable/x11/xprt-xprintorg.html

Notes:
- you may have to set the XPSERVERLIST env var before starting Mozilla
(I am not sure if the debian package does do that automagically)
- Xprint module is disabled in RPM builds (see 133534 comment #6)
- Xprint printers have a '@'-sign in the middle. If they start with
"Postscript/" then the old Postscript module is being used
attachment 106198 [details](above) is generated from ps module
Blocks: 157675
Resolving WFM. based on comment #8
Status: NEW → RESOLVED
Closed: 21 years ago
Priority: -- → P3
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
The attachment of comment #8, is still like the .ps I saw ( comment #1 and #2 ).
It has the line around the box, unlike the ps in comment #4 ( generated using
xptr module ), which has not.

Why is the bug closed?
reopen
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Investigating...
Some clue:
in the ps file(generated by ps module), the clip is strange. And stroke cause
the border be shown.
Who know any relationship between clip and strok?
Assignee: rods → pete.zha
Status: REOPENED → NEW
This bug was fixed by the patch for bug 80190. See bug 187184, bug 190316, bug
194830, bug 211259, and maybe one or two others.
Status: NEW → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.