Open Bug 177496 Opened 17 years ago Updated 3 months ago

<em> text surrounded by italic text is not rendered in roman

Categories

(Core :: CSS Parsing and Computation, enhancement, P4)

enhancement

Tracking

()

People

(Reporter: dot, Unassigned)

References

(Depends on 1 open bug, )

Details

(Keywords: css-moz, testcase)

Usual typographical rules dictate that emphasis inside a block of italic text is
indicated by setting the emphasized text in roman. Mozilla doesn't do this, for
example in <address> sections.

<address>
Italic text.
<em>This should be roman.</em>
Italic again.
</address>

I don't know whether there are similar problems with CSS.
This is only really a valid bug for EM since it's the only thing that's normally
italic but not required to be.  It could also be valid for STRONG.

However, it requires some proposed features of CSS that don't exist yet.
Assignee: font → dbaron
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Component: Layout: Fonts and Text → Style System
Ever confirmed: true
Keywords: css-moz
OS: FreeBSD → All
QA Contact: ylong → ian
Hardware: PC → All
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future
What is it that CSS doesn't have that's needed?  It seems to me we could simply
write a rule to the effect of:

  address em {font-style: normal;}

Perhaps better, the author/user can do this.  Or are you saying that CSS offers
no way to write a generic "if X is surrounded by italic text, make sure it's
non-italic" rule?
Keywords: testcase
I think this should be closed... :)
Resolving WONTFIX. There seems to be no need for this and authors are perfectly
capable of doing such things themselves.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → WONTFIX
This is definitely not wontfix, and should eventually be fixed.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
QA Contact: ian → style-system
Assignee: dbaron → nobody
Status: REOPENED → NEW
Priority: P3 → P4
Target Milestone: Future → ---
You need to log in before you can comment on or make changes to this bug.