Closed Bug 1775043 Opened 2 months ago Closed 2 months ago

The CC settings panel in PiP window can only be closed by clicking on the CC settings icon

Categories

(Toolkit :: Picture-in-Picture, defect)

Firefox 103
Desktop
All
defect

Tracking

()

VERIFIED FIXED
104 Branch
Tracking Status
firefox-esr91 --- disabled
firefox-esr102 --- disabled
firefox101 --- disabled
firefox102 --- disabled
firefox103 + verified
firefox104 --- verified

People

(Reporter: ada.cristea, Assigned: niklas, NeedInfo)

References

Details

(Whiteboard: [fidefe-MR1-2022])

Attachments

(1 file)

Note

  • When the user launches the PiP and opens the subtitle settings panel in PiP window by clicking the subtitle settings button, the user will notice the subtitle settings panel can only be closed by clicking the subtitle settings button again.
  • The panel will close if the user moves cursor out of the PiP window area (non full-screen).

Found in

  • Nightly 103.0a1

Affected versions

  • Nightly v103.0a1

Affected platforms

  • Mac OS 11.6 (Big Sur)
  • Ubuntu 20.04
  • The issue does not affect Windows 10 and Windows 7 platforms.

Steps to reproduce

  1. Launch browser in a new profile.
  2. Play any video.
  3. Launch the PiP window.
  4. Click the CC settings icon to open the panel.

Expected result

  • The user is able to close the CC settings panel by clicking on the PiP window.

Actual result

  • The used is able to close the CC settings panel only by clicking the settings icon.

Regression range

  • No regression.
Hardware: All → Desktop
OS: Unspecified → All
Has STR: --- → yes

I can confirm that this behavior is somewhat intermittent but mostly reproducible.
Also, this also reproduces on the Windows platform if the user clicks at the right or left of the PiP buttons (the buttons get hidden, but the subtitle settings panel remains displayed.

The bug is marked as tracked for firefox103 (beta). However, the bug still isn't assigned and has low severity.

:yshash, could you please find an assignee and increase the severity for this tracked bug? If you disagree with the tracking decision, please talk with the release managers.

For more information, please visit auto_nag documentation.

Flags: needinfo?(yshash)
Assignee: nobody → nbaumgardner
Status: NEW → ASSIGNED
Attachment #9283717 - Attachment description: Bug 1775043 - Hide subtitles setting panel when clicking on PiP window. r=#pip-reviewers → Bug 1775043 - Hide subtitles setting panel when clicking on PiP window. r=#pip-reviewers!
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Severity: S3 → S2
Flags: needinfo?(yshash)

The patch landed in nightly and beta is affected.
:niklas, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox103 to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(nbaumgardner)

This fix also changes the behavior of the panel more than I'd hoped:

Ubuntu 22 and Mac OS 11/12

  • Before the fix:
  • The panel would not close by clicking anywhere else inside the PiP
  • The panel WOULD close when the cursor left the PiP
  • The panel would NOT close when going into full screen
  • The panel WOULD close when leaving fullscreen
  • After the fix:
  • The panel WOULD properly close when clicking anywhere else inside the PiP (both full screen and not)
  • The panel would NO LONGER close when the cursor left the PiP area
  • The panel WOULD close when going into full screen or leaving it

Windows 7

  • Before the fix:
  • The panel would not close by clicking anywhere else inside the PiP (both full screen and not)
  • The panel WOULD close when the cursor left the PiP
  • The panel would NOT close when going into fullscreen or leaving it
  • After the fix:
  • The panel would close when clicking anywhere inside the PiP, but ONLY IN FULLSCREEN mode
  • The panel would NO LONGER close when the cursor left the PiP area
  • The panel WOULD close when going into full screen or leaving it

Windows 10

  • Before the fix:
  • The panel WOULD close when clicking anywhere else inside the PiP, but ONLY IN A SMALL PiP (not in fullscreen)
  • The panel WOULD close when the cursor left the PiP
  • After the fix:
  • The panel would close when clicking anywhere inside the PiP, but ONLY IN FULLSCREEN PiP (not in small PiP)
  • The panel would NO LONGER close when the cursor left the PiP area

As you can observe, this got a lot more complicated. I would say this is a partial fix.
How would you advise we address this bug, further? Should we close it and open others or should we reopen this one?
Any feedback is appreciated! Thank you.

Flags: needinfo?(asafko)

This bug only fixes the issues on macOS and Linux.

In Windows the onclick handler doesn't receive click events because the PiP window is a drag-able window so I still need to figure out why that happens. But I thought it was best to fix this for macOS and Linux in the meantime.

Flags: needinfo?(nbaumgardner)

Comment on attachment 9283717 [details]
Bug 1775043 - Hide subtitles setting panel when clicking on PiP window. r=#pip-reviewers!

Beta/Release Uplift Approval Request

  • User impact if declined: We want this patch to go to release with the subtitles settings patch. This patch fixes undesirable behavior when clicking on the PiP window.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Can only test on macOS and Linux.
  1. Go to any video with subtitles and open a PiP window
  2. Click the subtitles button to open the subtitles settings panel
  3. Click anywhere on the PiP window (that's not a button)

Result: the subtitles settings panel will close

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk because this changes the click behavior to hide the subtitles settings panel in a PiP window only.
  • String changes made/needed: No
  • Is Android affected?: No
Attachment #9283717 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9283717 [details]
Bug 1775043 - Hide subtitles setting panel when clicking on PiP window. r=#pip-reviewers!

Approved for 103.0b5, thanks.

Attachment #9283717 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The current behavior is acceptable for the 103 release IMO.

I do not think the behavior on click OUTSIDE of the PiP window is critical, and there's a super strong case for closing the panel when the user clicks outside the PiP (as before the fix) - the user interacts with some secondary task and might want the panel open for a second it takes to finish that task and return to PiP.

The only issue I feel is important:

The panel would close when clicking anywhere inside the PiP, but ONLY IN FULLSCREEN PiP (not in small PiP)

Niklas, do you feel like there's a chance to investigate this by the end of the week or it is likely a larger lift?

Flags: needinfo?(asafko) → needinfo?(nbaumgardner)
See Also: → 1778287

Taking into account Niklas's comment 7 (this was a fix for Ubuntu and Mac OS) and Ania's comment 11 (it's OK that the panel no longer closes when leaving the PiP area), then the behavior seen on Mac OS 11 and Ubuntu 22 (Wayland) is the expected one.

I can verify this fix in Nightly v104.0a1 for Mac OS 11 and Ubuntu 22 (Wayland) and log another bug for the Windows 7 and 10 platforms (bug 1778287).

I've verified the fix on MacOS 11 and Ubuntu 22.04 using Firefox Beta 103.0b5 (20220705185846)
The fix introduced Bug 1778287 on Windows (Comment 12)

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.