onChange not working properly when the keyboard is used

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: Damian Minkov, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

When you use the mouse the onChange event is fired properly. But when you use
the keyboard and move down and up the options it isn't been invoked. I tried
this in some other browsers and this is working.
It is used when you have a list of options and they are linked with other fields
and when you change the option the other fields avlues are changing and the
keyboard the selecting is faster.

Reproducible: Always

Steps to Reproduce:
1.Click to select the select input type
2. use the keyboard to move up and down nothing happens
3. use mouse and alert is saying hello

Actual Results:  
when using keyboard nothing happens

Expected Results:  
an alert must say hello. So the onChange must be called

Comment 1

15 years ago
not bugzilla. please choose select the appropriate product (browser) before
selecting a component.
Assignee: myk → form
Component: User Interface → Layout: Form Controls
Product: Bugzilla → Browser
QA Contact: matty → tpreston
Version: unspecified → other
This is done on purpose to allow keyboard-only users to actually select an
option... (with the other browsers' implementation this is quite difficult). 
Hitting "tab" or "enter" to indicate that you are done selecting the option will
trigger the onchange event.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
This is a dup of bug 126379.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.