Closed Bug 1776082 Opened 2 months ago Closed 1 month ago

Contacts list should have min-height for small window sizes

Categories

(Thunderbird :: Address Book, defect, P3)

Thunderbird 102

Tracking

(thunderbird_esr91 unaffected, thunderbird_esr102? fixed, thunderbird103? fixed)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird_esr102 ? fixed
thunderbird103 ? fixed

People

(Reporter: thomas8, Assigned: aleca)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

STR

  • New AB, vertical layout, reduce horizontal window size until contact list stacks on top of contact view.
  • Then reduce vertical window size bottom-up until the contact view stops moving.

Actual

  • search field and contacts list no longer visible, see screenshot

Expected

  • Contacts list should have min-height for small window sizes.
  • AB search box and 1 contact row should always be visible.

Before it goes to min-height for the top section, maybe some ratio like 1:2 between the list and contact display could do.

Blocks: tb102found
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 104 Branch

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/5f9af7043b9f
Add a min-height for the cards list in new Address Book. r=#Paenglab

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED

Comment on attachment 9284071 [details]
Bug 1776082 - Add a min-height for the cards list in new Address Book. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: The contacts list doesn't have a min height when the window is small
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low, just a small CSS change

Attachment #9284071 - Flags: approval-comm-esr102?
Attachment #9284071 - Flags: approval-comm-beta?

Comment on attachment 9284071 [details]
Bug 1776082 - Add a min-height for the cards list in new Address Book. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9284071 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9284071 [details]
Bug 1776082 - Add a min-height for the cards list in new Address Book. r=#thunderbird-reviewers

[Triage Comment]

Attachment #9284071 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.