[FIXr]disabled inputs should not be in tab order

VERIFIED FIXED in mozilla1.3alpha

Status

()

Core
Keyboard: Navigation
P1
normal
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

Trunk
mozilla1.3alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

BUILD: Linux build 2002-10-25-08.

STEPS TO REPRODUCE:
1)  Load bugzilla attachment page
2)  Tab to "patch" checkbox
3)  Hit "space"
4)  Try to tab to submit button

ACTUAL RESULTS:  Lots of tabs needed

EXPECTED RESULTS: disabled radio buttons not in tab order
Created attachment 104721 [details]
testcase

<select> and <textarea> do it right; all the <inputs> do it wrong.
Comment on attachment 104721 [details]
testcase

I need to stop the drinking...
Attachment #104721 - Attachment is patch: false
Attachment #104721 - Attachment mime type: text/plain → text/html
Created attachment 104723 [details] [diff] [review]
no stomping on "disabled"
reviews?
Assignee: aaronl → bzbarsky
OS: Linux → All
Priority: -- → P1
Hardware: PC → All
Summary: disabled inputs should not be in tab order → [FIX]disabled inputs should not be in tab order
Target Milestone: --- → mozilla1.3alpha

Updated

15 years ago
Attachment #104723 - Flags: review+

Comment 5

15 years ago
Looks like timeless already marked this reviewed, but r=akkana too.

+      if (child->IsContentOfType(nsIContent::eHTML)) {

Is this faster than the QI, or more accurate?
It's definitely a lot faster.  At the moment they're equally accurate...
Comment on attachment 104723 [details] [diff] [review]
no stomping on "disabled"

sr=bryner
Attachment #104723 - Flags: superreview+
Summary: [FIX]disabled inputs should not be in tab order → [FIXr]disabled inputs should not be in tab order
fix checked in for 1.3a
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
Comment on attachment 104723 [details] [diff] [review]
no stomping on "disabled"

a=asa for checkin to the 1.2 branch (on behalf of drivers)
Attachment #104723 - Flags: approval+
fixed on branch
Keywords: fixed1.2
vrfy'd fixed with 2002.11.19 comm trunk builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.