Closed Bug 1776644 Opened 2 months ago Closed 2 months ago

screen-reader-only class in email table disrupting Orca table navigation

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 104
defect

Tracking

(thunderbird_esr102 fixed, thunderbird103 fixed)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr102 --- fixed
thunderbird103 --- fixed

People

(Reporter: henry, Assigned: henry)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [TM:102.0.1optimistic])

Attachments

(1 file)

From bug 1774174 comment 7

Steps to reproduce with Orca:

  1. Navigate to the addressbook table and add two rows.
  2. Focus the second address input.
  3. Insert+A to switch to browse mode.
  4. Shift+Alt+ArrowRight. Moves to the checkbox, and announces row and column.
  5. Shift+Alt+ArrowUp. Moves to the checkbox on the first row, and announces row and column.
  6. Shift+Alt+ArrowLeft. Moves focus to email address input, and announces row and column.
  7. Shift+Alt+ArrowLeft. Moves focus to the selector, and announces row and column.
  8. Shift+Alt+ArrowRight. Does nothing!

Basically, as soon as you get to the first column, you get trapped there. I tracked it down, and, ironically, it is caused by the screen-reader-only rule:

position: absolute;

https://searchfox.org/comm-central/rev/299e3791e29995873d344ab0d6ac2202ebba93f6/mail/themes/shared/mail/vcard.css#246

Removing the line gets it to work. I think it may have to do with the fact that browse mode takes the screen position of elements into account, and the lack of a position may be throwing it off. Not sure if this would be considered a bug with Orca.

We move the screen-reader-only class to a contained <span> element instead. Thus the <span> has position: absolute applied to it instead of the <th>, but the <th> still has the required text content.

Assignee: nobody → henry
Status: NEW → ASSIGNED
See Also: → 1774174
Keywords: access
Version: unspecified → Thunderbird 102
Version: Thunderbird 102 → Thunderbird 103
Version: Thunderbird 103 → Thunderbird 104

Pushed by nicolai@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/1c38fde68b4b
Avoid screen-reader-only class on <th> elements in addressbook email table. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9283015 [details]
Bug 1776644 - Avoid screen-reader-only class on <th> elements in addressbook email table. r=aleca

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Broken table navigation when using Orca
Testing completed (on c-c, etc.): Tested manually with Orca
Risk to taking this patch (and alternatives if risky): Low. Minor change to the markup.

Attachment #9283015 - Flags: approval-comm-beta?

Comment on attachment 9283015 [details]
Bug 1776644 - Avoid screen-reader-only class on <th> elements in addressbook email table. r=aleca

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Broken table navigation when using Orca
Testing completed (on c-c, etc.): Tested manually with Orca
Risk to taking this patch (and alternatives if risky): Low. Minor change to the markup.

Attachment #9283015 - Flags: approval-comm-esr102?
Target Milestone: --- → 104 Branch

Comment on attachment 9283015 [details]
Bug 1776644 - Avoid screen-reader-only class on <th> elements in addressbook email table. r=aleca

[Triage Comment]
Approved for beta

Attachment #9283015 - Flags: approval-comm-beta? → approval-comm-beta+

optimistically approving for TB102.0.1 - assuming it will pass beta over the next several days

Whiteboard: [TM:102.0.1optimistic]

Comment on attachment 9283015 [details]
Bug 1776644 - Avoid screen-reader-only class on <th> elements in addressbook email table. r=aleca

[Triage Comment]
Included in 102.0.1.

Attachment #9283015 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.