Addressbar search loses/messes up scandinavian characters

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Reni Waegelein, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

Addressbar search misinterprets at least the scandinavian characters. Letter "ä"
(a with two dots) should be changed to %E4, "ö" (o with two dots) to %F6, etc.
Now they are converted to something else. This might happen to other characters
also, but I have not tested it.

I also noticed that separate google searchbar sometimes drops out the last non
7-bit character.

Reproducible: Always

Steps to Reproduce:
1. Write e.g. "kääpiö" into addressbar and press enter.
2. 
3. 

Actual Results:  
You end up to http://www.granthamandira.org/ggm/ggm.php?action=main

Expected Results:  
You should go to http://www.ursa.fi/yhd/sirius/vk.html

Comment 1

16 years ago
Reproduced with a build from today on Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
André, can you reproduce this in the latest Mozilla nightly? If so, this isn't a
Phoenix bug.

Comment 3

16 years ago
I cannot reproduce this with Mozilla, but that may be because it's stupid enough
to go to Netscape search even though I have Google selected as my search engine
(I thought that bug was fixed...).

Comment 4

16 years ago
you need to disable internet keywords in your Mozilla preferences to test this.
I'm quite sure this is a Mozilla bug and not a Phoenix bug.

Comment 5

16 years ago
*** Bug 177876 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021102 and
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021101 Phoenix/0.4
both goes to the same page, although I end up on
http://www.villipohjola.com/item.asp?Section=11&Item=112. That seems to be the
searchresult for "kääpi"

To reproduce this in Mozilla you need to enable internet keywords and adding
user_pref("keyword.URL",
"http://www.google.com/search?btnI=I%27m+Feeling+Lucky&q=");, which is what
Phoenix uses.

Comment 7

16 years ago
Well, then this is not a Phoenix specific bug.
Component: General → Browser-General
Product: Phoenix → Browser
Version: unspecified → other
(Reporter)

Comment 8

15 years ago
Could not reproduce on:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02 

Still reproducible on:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla
Firebird/0.6

This bug only exists for default search. If I self-declare a Quick search to
google (like http://www.google.com/search?&q=%s) the search works fine.

Updated

15 years ago
Summary: Addressbar search looses scandinavian characters → Addressbar search loses/messes up scandinavian characters

Comment 9

15 years ago
WFM,  Gecko/20031216 Firebird/0.7+, Windows XP.

Comment 10

15 years ago
worksforme with 2004021709 seamonkey build on winXP.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 11

15 years ago
Does not work for me:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

You can not make a search using Swedish characters since they are not handled
correctly.

It does work in:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Comment 12

15 years ago
Reopening based on comment 11
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

15 years ago
OS: Windows 2000 → All
Product: Browser → Seamonkey
*** Bug 270120 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
Bug 270120 has nothing to do with this bug, and it is not even close to be
duplicate. That is a bug concernig Yahoo search plugin and its unability to use
unicode characters. This bug is about searching from addressbar, it uses Google
by default and has no logical connection with bug 210120.

Also to mention that this bug is not reproducible on my system, while bug 270120 is.
(Reporter)

Comment 15

13 years ago
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919
Firefox/1.0.7 on Windows XP
Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
on Linux RedHat

Haven't noticed this bug in recent Firefox releases. Marking this as resolved.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.