Can't customize toolbar after javascript console

VERIFIED WORKSFORME

Status

()

Firefox
Toolbars and Customization
VERIFIED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Tom Sommer, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
I was playing around with the javascript console and I typed in
"document.write("hello");" just for fun, then I evaluated this and closed the
console window, I then went to the toolbar (the one with the URL edit field
etc.) and clicked customize and draged the phoenix icon on the toolbar, after
this I closed the customize menu and when I try to click the "customize..."
item, I get a small minimized window in the top left corner of the browser and a
Download Window that says:

You have chosen to download a file of type: "XML-Based User Interface Language" 
[mozilla.application/cached-xul] from chrome://global/content

When I click cancel, ALL toolbars are disabled, I can't click on anything
(Reporter)

Comment 1

15 years ago
The bug only apears when the customize window is accessed by the main toolbar...
If it is accessed by View -> Toolbars -> Customize... the bug will _not_ show

Comment 2

15 years ago
wfm - Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029
Phoenix/0.4

Evaluating "document.write("hello");" in the Javascript console just gives me an
eggtimer cursor in the console window.
(Reporter)

Comment 3

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

I don't think the error is because of the javascript.. I can't can't seem to
find a way to provoke it, I can reproduce it by clicking on the customize... in
the toolbar (the one with the URL field) and then the correct dialog comes up,
but when I do it a second time... I get the error, very strange

Comment 4

15 years ago
Reporter, please provide clears steps to reproduce. Read the bug writing
guidelines: http://www.mozilla.org/quality/bug-writing-guidelines.html
Severity: major → normal
(Reporter)

Comment 5

15 years ago
How to reproduce? ok, well... I right click the bar, and choose customize...
then it works... I get the dialog with the elements...

Then I close the dialog, and click customize... again.. now I get the error
stated in the original report... 

I've attached a link/URL to a screenshot so that you can see the elements... and
the error..
URL: http://pub.tsn.dk/Screenshots/phoenix_error.jpg

Perhaps it's the combination of elements?

Comment 6

15 years ago
I think this could very well be profile corruption. Have you tried creating a
new profile? Also, please install Phoenix to a clean directory (don't overwrite
an old installation).

If the steps to reproduce it are to visit Customize Toolbar twice in a row by
right-clicking on the toolbar, then I cannot reproduce on Linux with a build
from today.
(Reporter)

Comment 7

15 years ago
I did install from a clean diretory.

Sorry to be asking, but how do I manage profiles with phoenix, I havn't got
Mozilla installed
(Reporter)

Comment 8

15 years ago
The old profile (with the problem) also works now, so maybe it has been fixed
since the 0.4 release... I'm running the nightly from today

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021031 Phoenix/0.4

Comment 9

15 years ago
Resolve as WORKSFORME based on comment 8. Tom, please reopen this if you should
run into it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 10

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
Taking QA Contact
QA Contact: asa → bugzilla

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.