Closed Bug 17770 Opened 25 years ago Closed 25 years ago

[DOGFOOD] Backend: Multipart Alternative with a multipart/related message is not working

Categories

(MailNews Core :: Composition, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rhp, Assigned: rhp)

Details

(Whiteboard: [PDT-])

There is a problem when you send a multipart/related message and wish to have
it go out as multipart/alternative (i.e. both plain text AND HTML) I know what
the problem is, but fixing it is tricky.

Of course, we still don't expose this to the user in the UI yet, but I know
it's broken so I want to fix it.
Status: NEW → ASSIGNED
Target Milestone: M12
Whiteboard: [PDT-]
Since not in UI yet, putting on [PDT-] radar.
Blocks: 18471
Summary: [DOGFOOD] Multipart Alternative with a multipart/related message is not working → FIXED: [DOGFOOD] Backend: Multipart Alternative with a multipart/related message is not working
I have this complete in my tree...will try to get checked in today....yeahhh.
Phil, I just put you on the cc list to see this is done, but it's only the
backend...I didn't hook up the menu item. I will see if that looks easy and I
can try to do it, but I'm sure JF could probably do it without thinking.

- rhp
Good work, RIch. I bet you can handle the menu item :-)
Status: ASSIGNED → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
Summary: FIXED: [DOGFOOD] Backend: Multipart Alternative with a multipart/related message is not working → [DOGFOOD] Backend: Multipart Alternative with a multipart/related message is not working
All done.

- rhp
So, no way for us to verify without UI hookup, correct?  If so, maybe Rich or
Phil could make sure the fix is in and mark verified (or let me know and I'll
mark verified)?  Thanks.
No, the UI is hooked up now. You can select the format of the message off of
the "Message" menu and select force plain text, both, etc...

- rhp
Oh, OK. Thanks.
Oh, and (minor detail) what symptom(s) would the problem have shown?
The way it was before, the message was built incorrectly..and you wouldn't see
any body. Now it "should just work"

- rhp
OK using 12-10-08m12 commercial build on NT 4.0
Status: RESOLVED → VERIFIED
OK using 12-10-08m12 commercial on Mac OS 8.5.1
Having problems due to other bug on Linux, so will assume OK there.
Marking verified.
No longer blocks: 18471
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.