Location of linked files are altered to cid protocol. Cannot open linked network files in email.

VERIFIED DUPLICATE of bug 174804

Status

MailNews Core
MIME
--
major
VERIFIED DUPLICATE of bug 174804
16 years ago
10 years ago

People

(Reporter: Doug Fleschute, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla 1.0 through 1.2n

Our company uses network files accessable to all employees.  When a file must be
viewed by a large number of people, they will send an email with a link to that
file.  In Netscape 4.x, the recipient of the email, someone with access to the
same network files, would click on the link which would open the file in the
appropriate application.  When this is attempted in Mozilla, the file will not
open with a single or double click.  The only right click option that will work
is to bookmark the link.  When attempting to use the bookmark to open the file,
an error message is received.  "cid is not a registered protocol".  The bookmark
properties show the problem.  The Name of the bookmark shows the proper path to
reach the file.  However, the Location portion is completely different.  This is
the display shown for one such location. 
cid:part1.06040708.00090206@unionstation.org
Unionstation.org is the name of our organization.  What the link location should
have shown was a drive letter followed by the proper subfolders, and finally the
file itself.

Reproducible: Always

Steps to Reproduce:
1.email a file link (Word, Openoffice, some kind of document) on your network to
someone who has access to the same network.

2.Attempt to open the link with a double or single click
3.If that works, you've had more luck than I
4. Try using any of the right click options.  Bookmarks should be the only one
that works.
5. Try to open the bookmark.  You should receive an error message.
6. Look at the bookmark properties.  Is the location path correct, or has it
been  altered to a CID format?

Actual Results:  
They were described above.

Expected Results:  
They were described above.


I've listed this as major in the severity because it has been used extensively
by our company for quite some time.  Altering this would cause a major load on
our network (i.e. sending files as attachments instead of links would increase
the network traffic exponentially).

Updated

16 years ago
QA Contact: gayatri → stephend
(Assignee)

Comment 1

16 years ago
This is a dup of bug 174804 for which I have a fix.

*** This bug has been marked as a duplicate of 174804 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.