page render fault on secondary display when using different resolution from primary display in multiple monitor configuration

RESOLVED DUPLICATE of bug 159552

Status

defect
--
minor
RESOLVED DUPLICATE of bug 159552
17 years ago
17 years ago

People

(Reporter: sacha-moz, Assigned: saari)

Tracking

Details

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021031 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021031 Chimera/0.5+

I'm using a Powerbook. My primary display is 1152x768. I have a second monitor
attached. Its resolution is 1280x1024. When running navigator on the second
monitor, if I make the browser window taller than the height of the primary
display (768), the background for the portion of the page that extends below 768
is rendered as the default aqua striped background. The status bar at the foot
of the page and the scrollbar render correctly. Scrolling does not correct the
display.

Reproducible: Always

Steps to Reproduce:
1. connect second monitor
2. set resolution of second monitor to be taller than primary display
3. open navigator
4. move navigator window to second monitor
5. resize navigator window to be full height of second monitor

Actual Results:  
(See details.)

Expected Results:  
Rendered the portion of the page that extends below the height of the primary
display.

Resizing the window to be a height less than or equal to the primary display
results in normal behaviour.

Comment 1

17 years ago
The old localstore.rdf/dual-display bug?

Comment 2

17 years ago
The bug, or something like it is still present: 

Darwin rotarran 5.5 Darwin Kernel Version 5.5: Thu May 30 14:51:26 PDT 2002;
root:xnu/xnu-201.42.3.obj~1/RELEASE_PPC  Power Macintosh powerpc

Build ID: 2002120704

Ti book with a small local display and a huge monitor pluged into the monitor
port on the back. 

It looks is if the window cliping routines, or backing store routines are
getting there clipping size from the primary monitor, not the largest monitor,
the union of all the monitors, or the current monitor.

What is actuily happening: 

The page lays out correctly.  If the window is larger than the first display's
current resolution, the page layout is cutt off at that size.  Where the rest of
the page, or background should be there is only the horizontal grey and white
bars that look to makeup the default background, the same as the menuebar.

When scrolling the problem doesn't get better.  For example if you scroll down
the page, the page does go up, but no new stuff shows up in the window, or it
does sporaticly in horizontal bands.

To half fix the problem you can resize the window.  This causes a redraw that
seems to get everything happy again untell you scroll some more.


-goodluck
Dup

*** This bug has been marked as a duplicate of 159552 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.